Jump to content

Solax inverter - comms with Pylontech US3000C BMS


PtaSolar

Recommended Posts

Good morning to all the guru's (I am technical ignoramus - and Newbie on this site, plse excuse any breaches of protocol - I have posted this same message under the battery topic sub/old existing thread)

I just replaced the previous batteries on my system with 3 Pylontech US3000C batteries - similar to other people (Deejay and Occo in a different thread) I have problems connecting the battery BMS to my inverter as the US3000C has a RS485 port while my inverter has a RS232 comms port. I have a Solax SK-SU5000E inverter.

I see that that Deejay and Occo found a solution for their comms cable problems and if anybody could help me to similarly find out what the pinouts must be to connect the batteries to my inverter I would be extremely grateful. Even if someone can just give me a reference to an expert who might know - After spending what I consider to be a lot of money on the batteries which are currently paperweights I would really be willing to pay a lot for a solution!!

I have contacted the battery supplier and Solax, but without any joy to date.

Edited by PtaSolar
Spelling error
Link to comment
Share on other sites

  • PtaSolar changed the title to Solax inverter - comms with Pylontech US3000C BMS
  • 3 weeks later...

I'm running a SOLAX XHybrid SK-SU3700 inverter and have pins 1&2 (CAN-H, CAN-L) at the inverter linking to pins 4&5 (CAN-H, CAN-L) at the battery (RJ45 plug in A-CAN port of master battery and that seems to be working (no BMS Lost message on inverter) - I got this info from Pylontech after myself having cabling problems.  Oddity though is that the Battery capacity reported by the Inveter drops quickly from 100% (over 30mins) to stabilise at 50% for the majority of the battery capacity life  (as observed by the lights on the front of the batteries) and then slowly drops to around 45%....

 

Link to comment
Share on other sites

  • 4 months later...

Hi. Sorry to bring up an older topic, but I'm really seeking some advice on this as well.
I also have an SK-SU3700 and have gone for 3 x US3000C batteries to replace my two Extra 2000 batteries.

The previous batteries had an RS232 interface which interacted with the inverter really well - in the status, it would show that BMS was connected, and if I unplugged that cable, it would show a BMS lost error message.

With the new set up, I've tried pins 1 & 2 at the inverter, and pins 4 & 5 at the battery (I also included pin 3 at the inverted to pin 6 at the battery for ground).
It doesn't seem to complain, but equally doesn't seem to do anything either - it shows BMS disconnected in the status, and unplugging the cable seems to have no effect.
I also tried wiring the Console connection from the battery to the inverter (using the documented pinouts for RS232), but that didn't seem to communicate either.

I ended up manually configuring 45.9V discharge cutoff voltage (45.5 was too low and caused an alarm), and 52.4v charge cutoff voltage (as recommended by Victron somewhere).
I also upped the charge and discharge current to 75A (25A for each battery pack seemed fair, and I have 80A fuses on the DC)

These figures seem to allow the battery to operate pretty well with the Solax inverter, but there doesn't seem to be any battery communication at all. The inverter uses the voltage to determine the SOC which is wildly inaccurate!!

Pylontech report that the US3000C batteries are compatible with the SK-SU range of inverters, but I'm not sure to what level. I assumed that the BMS would be able to communicate, but am now wondering if my expectations were too high.
Does 'compatible' just mean that they'll work together for battery storage provided you get the manual settings reasonably correct? Or is it fully compatible, and should I be able to get the battery to report full information to the inverter?!

I'd love to know if anyone has a similar set up, and how they ended up configuring it all.

Thanks.

 

Link to comment
Share on other sites

  • 1 month later...

Nope - no joy yet.
I gave up emailing Pylontech and Solax - all of my messages just went unanswered.

The manual settings do seem to be working OK for charging and discharging, but it would be nice to get some accurate info from the BMS.

Does anybody have any suggestions here? The Solax seemed to work so much better with the old Extra 2000 batteries.

Link to comment
Share on other sites

  • 9 months later...

A year down the line and i was just wondering if anybody has had any luck with this.

Every so often, I take another look into it to see if I can work anything out.

I did just look up the Extra 2000 specs (the batteries I had before the US3000Cs), and the BMS port on that looks as though it was RS232 only.

I have just tried wiring the Solax to the Console port on the US3000C, but I'm not hopeful!

Link to comment
Share on other sites

  • 4 weeks later...

OK - I've had a really good look into this, and have got.... somewhere! Just not quite where I want to be.

After a little project whereby I can now get my US3000C data from the batteries into Home Assistant via a CAN-Ethernet converter and Node Red, I thought I'd start trying to debug things on the Solax end. This is for my Solax SK-SU3700 which supposedly has CAN on pins 1 and 2, and RS232 on pins 4 and 5.

Using the CAN-Ethernet on the Solax connection, there did not seem to be any activity at all on pins 1 and 2, so I don't think CAN actually functions on there.
I then used an RS232-Ethernet converter on pins 4 and 5.

With that connected, I could see the following data sent every 5 seconds or so at 1200bps:

~2001464F0000FD99\n (the \n is a carriage return)

After A LOT of researching online, I was able to determine that this was the RS232 format specified by Pylontech, and that particular command is a request for the communication parameters.

I also noted how similar it looks to the command that is used to get the Pylontech batteries into 'debug/communication' mode when connecting through the console/rs232 port.
Apparently, if you connect at 1200bps, and then send the command ~20014682C0048520FCC3\n, you can then switch to 115200bps and will see the prompt:

pylon>

 

Next, I turned my attention to the Console port on the US3000C and connected using a terminal session on my computer.

Initially I connected at 1200bps and sent '~2001464F0000FD99\n' (the same info as sent by the inverter), but just got gibberish.

I gradually increased the baud rate, and eventually when connecting at 115200bps and sending '~2001464F0000FD99\n', I received the following:

@
Unknown command '[18]˜à[18][1E]x[18][1E]x[06][18][18][18][18]``f˜ø˜[1E]~2001464F0000FD99' - try 'help'
$$
pylon_debug>

 

So, it would appear that the US3000C is in 'debug/comms/whatever you want to call it' mode already, and therefore, the query being sent by the Solax is not being processed as it should.

Does anybody know if it's possible to get the US3000C console port in to whatever mode earlier versions had?
I'm sure that if we can revert it back somehow, it would then work with the Solax inverters by running a cable between the BMS port on the Solax and the Console port on the Battery.
 

For reference, I have the newer hardware revision running the latest v1.8 firmware (as opposed to the older style running v2.8 firmware).
I don't know whether this change in the Console port is due to the fact it's a model C or whether it is some change that occurred between the two different hardware revisions.

Link to comment
Share on other sites

I've just had a quick look through the RS485 protocol docs from Pylontech, and it looks like (although it was a very brief look) it's identical to their RS232 communication protocols.

As a result, it might be possible to just put a RS232/RS485 converter in between the Solax BMS port and the Pylontech RS485 port.

I need to take a break from this now 😆, but I will take a closer look at the RS485/RS232 comm specs and will try it out at some point if it looks feasible!

Link to comment
Share on other sites

  • 2 months later...

how many types of solax hybrid inverters is there? i had solax 4.3kw (old model) a company sold me as (new model) crashed all the time from day one, shifted screen-brain-and parts all the time, cus of warranty case i ask if someone knows if solax always had problems ore is it just does from 10 years back? i now got the goodwe ES and have no idea how ore if good yet, had it for 1 week.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...