Jump to content

MQQT registration info

Recommended Posts

7 minutes ago, cvzyl said:

Machine ID is generated by the the software. You need to send it to Manie, he will generate a license key for you. Similar to ICC app.

Thanks. I imagine @Manie will see this. Please also let me know the port that I need to use with the IP. From what I understand the MQQT Windows App connects in to the MQQT "server" running on the Raspberry Pi. So I know the IP of this but am not clear which port that MQQT "server" uses. Also, if it is a special port, will I need to set up a firewall rule in the Raspberry to open it on the Raspberry? At the moment I am running MQQT Windows App on the local network with the Raspberry.


Link to comment
Share on other sites

11 minutes ago, Manie said:

Look at the pi settings. There is a place for mqtt and the port number

Sent from my SM-G920F using Tapatalk

The MQTT is great by the way. It means that normally you don't even need to worry about remoting in to the pi where ICC is running. For monitoring all I need to do, then, is just run this app. I will only need to remote in to the pi if I need to change mode or other settings. Makes a great add-on to ICC.

Link to comment
Share on other sites

5 hours ago, Manie said:

Is the data coming through on the pi?

Sent from my SM-G920F using Tapatalk

I now have the data coming through into ICC on the pi. I connected the USB to the "slave" Axpert inverter in the cluster and it works, as @Don mentioned. The only thing that doesn't seem to be configured correctly is the Emoncms feed. The Emoncms server is running on the same pi (not sure if that is a best practice) so it is localhost. In the settings tab in ICC I have entered the Emoncms API key and for the host "http://localhost/emoncms" but that is obviously not right as it doesn't send the data. Should I be using "" or something else?

Link to comment
Share on other sites

2 minutes ago, Don said:

Just enter the following under Emoncms Server : localhost/emoncms/ (without http)

Thanks, trying now ....

OK. That works - noteworthy that the trailing forward slash at the end of the address is required (not always the case).

Edited by incagarcilaso
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...