Jump to content

Infinisolar 3kw+ settings please...


Recommended Posts

  • Replies 170
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I had a similar problem. Every now and again I noticed that the PV power dropped quite a lot for a few minutes at a time while the skies are clear and the sun shines bright. My only thought was that o

A few guys contacted me directly with questions about "how much overload" the 3kw inverter can really take?. My assesment is that maximum load from grid is just below 30A (last peak measurement I

in order to try and get to better numbers for my Discharge limits, I decided to do a discharge test...   just a quick recap:   setup: infini3kP with 4x 200Ah Sonic Gel batteries.   load: all house

Posted Images

10 hours ago, superdiy said:

No this  Latest Firmware for Vertex / Infini 3K (06/2014)

I dont know pasword for unzip file for 3K plus.But I have normaly 3K

 

Before I have version DSP an MCU in 2013 years.(4,7,2013)

 

Now everithing works only NOISY fans newer dont stop.

 

 

 

 

Link to post
Share on other sites
  • 1 month later...

Hello here at the Powerforum :-)
I have read a lot of your posts and it seems you all have a lot of valuable knowledge! :-)

I have a question or two regarding my Infisolar 3kW from Voltronic. 
It is brand new -but from 2013. Set up with 2.000Wpeak panels and 4x100Ah lead-acid batteries.

Since it is from 2013 I had to run the Solarpower version 1.04 to be able to set the device parameters like Max/Min Grid voltage etc.
The standard "administrator" password is doing the job and the system is running.

The problem/question:
I have come to realize that since the inverter is produced back in 2013 it does not have all of the features that the newer models do.

The system is setup to run my garden pond pumps and a few other things.
Therefore I need it to do the following:
a) When PV available: 1: Power the load, 2: Charge the batteries  -but NEVER feed-in to the grid
b ) When PV not available: 1: Power the load from the batteries and when the batteries run down - power the load from the grid.
c)  never feed-in to the grid and never charge the batteries from grid.

On the newer versions these settings are easily done in the SolarPower software under the MyPower Management menu point.
But since my inverter is from 2013 -this menu point is not available.

So to the question:
What should I do?
As per standard setup -the inverter will both charge the batteries from the grid and feed-in to the grid when PV power is available.

-does any of you know how I could setup these things in my older inverter? 
I read some of you had success with sending commands via seriel interface to the inverter f.ex.

-or do you know if I could firmware upgrade the inverter to support these newer features?

From the device information my inverter has the following data:
Main CPU processor version: 3.10
Secondary CPU processor version: 0.32


I really hope that some of you can help me out  - as it is right now, I have a system that I can not run, since I am not allowed to feed-in to the grid!

Don't hesitate to ask further questions.

Hope to get your replies soon :-)

Greetings from Denmark
Jens Christian Nørtoft Bækgaard

Link to post
Share on other sites

Hi JCN, Welcome to the forum.

Jip, some pretty clever guys here to help you. They will be around momentarily to give you some good advices.

What all of us do, is we use a Victron BMV monitor to determine when to swap between grid and batteries. You do not want to run your batteries too low.

@edmundp could also guide you with how he did it with software.

Link to post
Share on other sites
7 hours ago, jcn said:

Infisolar 3kW from Voltronic

Since it is from 2013 I had to run the Solarpower version 1.04 to be able to set the device parameters like Max/Min Grid voltage etc.

From the device information my inverter has the following data:
Main CPU processor version: 3.10
Secondary CPU processor version: 0.32

Hi Jens Christian,

Although my inverter is an Infisolar 3KW Plus by Santech (model 3KW PV 4.5KW) my conversations with Santech is that it is essentially the same machine available with different shells for different countries (for the UK is branded Infisolar) I assume that it is a similar story for the Voltronic version.

My first comment is that my inverter was manufactured for Santech (China) in June 2015 with:

Solarpower version 1.04 ( Santech pointed me to a new version from their UK distributor but after downloading it I never found time to install it)
Main CPU processor version: 3.10
Secondary CPU processor version: 0.31

So I am a little puzzled by your question: I can set by Solarpower version 1.04  my inverter to do what you say you cannot do.

In particular at the moment I am running mode "Grid-tie with backup (II)" but with "Allow to feed-in to the grid" disabled (I also cannot feed to grid ... otherwise I will be charged for my supply) and I do not al;low grid to charge batteries (PV only). In this mode the Priority is: 1st load > 2nd battery > 3rd grid

After experimenting I have found this mode more efficient by ~ 2KWh per day than the standard  "Grid-tie with backup (I)" i.e.  Priority is: 1st battery > 2nd load > 3rd grid since batteries are only recharged with excess PV not used by load (I have 4000w panels and my production in sunny days in winter is generally slightly above 3000W).

I see little point in supplying load from batteries unless there is a power outage or voltage is very high.

Reason: my energy savings using batteries are not consistent enough to offset battery costs once I take into account increased PV production in mode  1st load > 2nd battery > 3rd grid (and my batteries are always ready for backup).

On issue of voltage very high: in June we had >250V during night hours (from 00:00 to 04:00) for more than a week and most appliances, neon lights, cold-room compressor as well as my APC UPS (it was going off-on-off-on-... indefinitely) were very unhappy/very noisy due to excessive voltage). It was very disappointing (and inconvenient) that  Solarpower version 1.04 was not able to be set to switch to battery mode when Voltage from grid was higher than a pre-determined voltage value. In theory "Grid-tie with backup (V)" should do just that but Solarpower version 1.04 was unable to send the correct command to the inverter (bug?). That meant that before going to sleep I had to manually set "load priority: battery-grid" and make sure I remembered to switch back to "load priority: grid- battery" before sunset.

I need to install a later version of Solarpower to check if this bug is resolved

Probably I don't understand your question correctly: can you please illustrate with  Solarpower screenshots why since my inverter is from 2013 -this menu point is not available?

If we have similar firmware (if anything it looks to me your Secondary CPU processor version is one step head of mine) and same Solarpower version this does not make any sense.

regards

Link to post
Share on other sites

I don't know the grid-tie models (InfiniSolar etc) very well, but it's possible that they use a similar technique to determine the hardware's capabilities (read from a general purpose digital input port some number that varies with the hardware capability). It's possible that the SolarPower is asking the inverter what its capabilities are, and adjusting its menus depending on that is read back. That would explain the differences seen.

But the various operating modes are quite numerous, so it also seems possible to me that jcn is using an inappropriate mode or other configuration detail.

Link to post
Share on other sites

Hello to all of you - thank you so much for your quick and good answers! :-)

Much appreciated!

But I think Coulomb is right about the communication between software and hardware ("what are your capabilites?" "-OK, then I adjust my menu's accordingly").

I also agree with you MaurizioZA about the setup. I would need the option: "Grid-tie with backup (II)"

The problem is - I don't get the possibility to choose these settings at all!

Can you confirm that you all use the menu point: "Device Control - MyPower Management" to set these options?
Or is there another way? (since I don't have this menu).
See attached image. That is a screenshot with a new manual (pdf) in the background showing the menu "MyPower Management" and the actual SolarPower software in front, where this menu point is not visible.

MaurizioZA, you mention your model as a 3KW plus model.
The one I have is not a "plus" model (see attached photo of the actual label). But since the CPU versions are the same or newer on my unit, it does not make much sence if my unit can not make these settings.

Futhermore it does not make sense at all to make an inverter without the option of choosing how it should behave...!?

I am puzzled! :-)

That is why I thought a firmware update might be the way to go -if possible? Do you know about that?

Thanks for your help :-)

Jens Christian, Denmark

 

SolarPower_settings.jpg

IMG_4931.JPG

Link to post
Share on other sites
18 hours ago, jcn said:

Since it is from 2013 I had to run the Solarpower version 1.04 to be able to set the device parameters like Max/Min Grid voltage etc.
The standard "administrator" password is doing the job and the system is running.

The problem/question:
I have come to realize that since the inverter is produced back in 2013 it does not have all of the features that the newer models do.

The system is setup to run my garden pond pumps and a few other things.
Therefore I need it to do the following:
a) When PV available: 1: Power the load, 2: Charge the batteries  -but NEVER feed-in to the grid
b ) When PV not available: 1: Power the load from the batteries and when the batteries run down - power the load from the grid.
c)  never feed-in to the grid and never charge the batteries from grid.

On the newer versions these settings are easily done in the SolarPower software under the MyPower Management menu point.
But since my inverter is from 2013 -this menu point is not available.

So to the question:
What should I do?
As per standard setup -the inverter will both charge the batteries from the grid and feed-in to the grid when PV power is available.

-does any of you know how I could setup these things in my older inverter? 
I read some of you had success with sending commands via seriel interface to the inverter f.ex.

-or do you know if I could firmware upgrade the inverter to support these newer features?

From the device information my inverter has the following data:
Main CPU processor version: 3.10
Secondary CPU processor version: 0.32

Hi jcn, have you tried to upgrade SolarPower to a later version?  I think the latest is 1.10. My inverter is a 2014 model with firmware 3.10 and 0.31 - you have 0.32 which, to me, looks like a later version than what I have.  I was able to adjust the settings you refer to from the initial version of SolarPower, which was bundled with the inverter and in all the versions of SolarPower thereafter.  I would suggest to try a later version of SolarPower and report back.

5 hours ago, Coulomb said:

I don't know the grid-tie models (InfiniSolar etc) very well, but it's possible that they use a similar technique to determine the hardware's capabilities (read from a general purpose digital input port some number that varies with the hardware capability). It's possible that the SolarPower is asking the inverter what its capabilities are, and adjusting its menus depending on that is read back. That would explain the differences seen.

But the various operating modes are quite numerous, so it also seems possible to me that jcn is using an inappropriate mode or other configuration detail.

Yes, the software does query the inverter's capabilities and it also looks at the FW2 value in quite a few places, but it only checks FW2 > 0.3 or FW2 <= 0.3 - I'm not sure what the difference between FW version 0.31 and FW version 0.32 would be, but both of those versions will have the same result in either the FW2 > 0.3 or FW2 <= 0.3 comparisons.

Link to post
Share on other sites
19 minutes ago, jcn said:

I also agree with you MaurizioZA about the setup. I would need the option: "Grid-tie with backup (II)"

The problem is - I don't get the possibility to choose these settings at all!

Image2.jpg

Don't you have the option to change this drop-down to "Grid-tie with backup (II)"?

Link to post
Share on other sites

Hi Superdiy :-)

Firt I tried with SolarPower version 1.05SP1 (the one I found for download first).

This had the menu option "MyPower Administration" as long as I do not attach the inverter. But as soon as I attach the inverter the menu point goes away.
With this version I could not set the device parameters either. It would not accept the "administrator" password...?

Then I went back to the SolarPower 1.04 that came on the disc with the inverter.
This can set the device parameters - but does not have the "MyPower Administration" menu point - nor with or witout the inverter attached...

Do you have a link to the 1.10 version?

Thanks :-)

Link to post
Share on other sites
4 minutes ago, superdiy said:

Image2.jpg

Don't you have the option to change this drop-down to "Grid-tie with backup (II)"?

no - as mentioned and shown in the screenshot - I don't have the "MyPower Management" menu point.
Not at all in version 1.04 and not with the inverter attached in version 1.05SP1

Link to post
Share on other sites
1 minute ago, jcn said:

no - as mentioned and shown in the screenshot - I don't have the "MyPower Management" menu point.
Not at all in version 1.04 and not with the inverter attached in version 1.05SP1

OK, I've now looked again at the image you've posted - I thought it was SolarPower on your PC, but now I saw that it is a screenshot with a manual in the background.

Link to post
Share on other sites
8 minutes ago, jcn said:

Hi Superdiy :-)

Firt I tried with SolarPower version 1.05SP1 (the one I found for download first).

This had the menu option "MyPower Administration" as long as I do not attach the inverter. But as soon as I attach the inverter the menu point goes away.
With this version I could not set the device parameters either. It would not accept the "administrator" password...?

Then I went back to the SolarPower 1.04 that came on the disc with the inverter.
This can set the device parameters - but does not have the "MyPower Administration" menu point - nor with or witout the inverter attached...

Do you have a link to the 1.10 version?

Thanks :-)

Version 1.10 available from: http://www.ostrovni-elektrarny.cz/index.php?page=podpora

Link to post
Share on other sites

The only way i can think of is to send the command manualy to the inverter and see if it accept it. If not you will get NAK return

Sent from my SM-G920F using Tapatalk

Link to post
Share on other sites

@ Jaco de Jongh - absolutely -and hope you will too :-)

@ Manie - I don't have the command set / instructions to send manual commands, but it would absolutely be something I would like to try!
Can you help me with that? -or someone else maybe? :-)

Thanks for all your help ! :-)

Link to post
Share on other sites

JCN,

 

From what I read it looks to me that firmware 0.32 prevents you from accessing "MyPower Management" menu. For what reasons I don't know and I would query this issue with Voltronic before attempting firmware updates.

My  point of view is that firmware should not be fiddled with unless there is certainty that it is correct for the hardware (but then nowadays firmware updates do check for hardware compatibility before updates).

It might be possible that you get an answer of the type "pay an additional fee and you will get the MyPower Management feature unlocked": at that point if I were you I would be prepared to try to change firmware to see if menu becomes unlocked.

In one of the earlier posts in this tread I read about a firmware upgrade for the 3kw from Voltronic: if I were to try one I would try that one.

Sending commands to inverter would work but it might not be a great idea since without the MyPower Management menu you would not be able to see what is going on with your inverter.

There are a couple of guys in this forum who have made their own enhanced management software (I am a little tight for time at the moment so please try to search this forum yourself ... or maybe someone else can point you to the topics ?) and I think they offer trial options: however you need to check if the Infini 3KW is supported. If they do this might be your best bet.

 

Link to post
Share on other sites
52 minutes ago, jcn said:

@ Jaco de Jongh - absolutely -and hope you will too :-)

@ Manie - I don't have the command set / instructions to send manual commands, but it would absolutely be something I would like to try!
Can you help me with that? -or someone else maybe? :-)

Thanks for all your help ! :-)

Tonight I will modify my setup and take note of the string which is sent to the inverter.

Somewhere on the forum there is a description on how to change some frequency/voltage parameters without factory password: you should then be able to send that string to your inverter and record the answer from the inverter (NAK if command is not accepted)

Link to post
Share on other sites
On ‎27‎.‎7‎.‎2016‎. at 2:02 PM, jcn said:

 

From the device information my inverter has the following data:
Main CPU processor version: 3.10
Secondary CPU processor version: 0.32

 

 

Hi,

 

I have older device. my serial no 961212051000031.I buy new,but i waiting for adaptacion roof.

Your is newer.and probably have blocking for software element.

I have mach problem with this device,but now work ok.

Try download Latest Firmware for Vertex / Infini 3K (06/2014)    http://www.ostrovni-elektrarny.cz/index.php?page=podpora

and after instalation opren reflash tool and only read version. Which is DSP and MCU and time.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Link to post
Share on other sites

Hello Hristo, thanks for your info.

I am not sure if I will take the risk of flashing it with another firmware yet - if possible I would like to try to send commands directly to the inverter. But I wait for a little more help on that one :-)

But maybe if all else fails.
Could you describe more in detail what you have done and what the result was.

Thanks :-)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...