Jump to content

Infinisolar 3kw+ settings please...


Recommended Posts

@ Jaco de Jongh - absolutely -and hope you will too :-)

@ Manie - I don't have the command set / instructions to send manual commands, but it would absolutely be something I would like to try!

Can you help me with that? -or someone else maybe? :-)

Thanks for all your help ! :-)

I fist need to check if the command is in the protocal doc. Mayby if someone with one that is working can put a sniifer to cach the command.

Sent from my SM-G920F using Tapatalk

Link to post
Share on other sites
  • Replies 170
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I had a similar problem. Every now and again I noticed that the PV power dropped quite a lot for a few minutes at a time while the skies are clear and the sun shines bright. My only thought was that o

A few guys contacted me directly with questions about "how much overload" the 3kw inverter can really take?. My assesment is that maximum load from grid is just below 30A (last peak measurement I

in order to try and get to better numbers for my Discharge limits, I decided to do a discharge test...   just a quick recap:   setup: infini3kP with 4x 200Ah Sonic Gel batteries.   load: all house

Posted Images

Sending commands to inverter would work but it might not be a great idea since without the MyPower Management menu you would not be able to see what is going on with your inverter.

There are a couple of guys in this forum who have made their own

There is commands to check all the settings. Just send the command and you will get the state op the inverter. All settings. Then you can send the command to change the setting and query it again to see if it is changed.

With the Axpert i can do all. Axpert also have a command that set the defualts. The infini will have the same. Only different commands without the CRC

Sent from my SM-G920F using Tapatalk

Link to post
Share on other sites
5 hours ago, MaurizioZA said:

Tonight I will modify my setup and take note of the string which is sent to the inverter.

Somewhere on the forum there is a description on how to change some frequency/voltage parameters without factory password: you should then be able to send that string to your inverter and record the answer from the inverter (NAK if command is not accepted)

Thanks to Wagga links to protocols and utility for sending commands can be found here:

RS232 Protocol.pdf

note: protocols are generic and possibly only valid for Axpert inverters (solar inverters which unlike Infini are not hybrid / do not feed grid). However most commands should be valid.

AccessPort_and_SOP_battery_calibration(1).rar

also read:

the above refers to adjusting min/max frequency without factory password but method is exactly same with other commands.

I have tried to tried to change inverter mode to capture the command string sent to inverter.

Since I was in "Grid-tie with backup (II)"  I switched to "Grid-tie with backup (I)".

GTS1 tied-to grid (I).jpg

the string is "GTS1" which inverter replied accepted (ACK9) ... and the re-booted :(

This test was a BIG mistake: I sent the command while my wife was preparing dinner and children doing their homework and I had forgotten that switching modes causes inverter to reboot thus leaving everyone in the house (including me) in the dark.

I had also forgotten that my computer is not linked to inverter by com cable but through Ethernet (+ WiFi) to com port via a WiFi rooter + Ethernet cable + com-to-LAN adapter: as inverter rebooted and power was cut to these devices my link PC-inverter was lost. It took me one hour to re-established link, switch back from  "Grid-tie with backup (I)"  to "Grid-tie with backup (II)", go through a second inverter reboot (and loss of power to the COM connection) and by the time I managed I realized that I had not captured the command string because I had been monitoring the old virtual com port (a new virtual port was created in my PC because previous port was busy monitoring the old broken connection). All this was done while everyone was shouting at me :(

Bottom line: I do not know for certain what the command string for switching to "Grid-tie with backup (II)" is.

Maybe "GTS2" ... or maybe not :D

I just know that I will not try this again until the weekend and when everyone is not at home: in a single hour I collected more insults and screams than I get in a whole year :D

 

Link to post
Share on other sites
1 hour ago, Manie said:

Sending commands to inverter would work but it might not be a great idea since without the MyPower Management menu you would not be able to see what is going on with your inverter.

Exactly.

I have been away from this forum for a while and I now realize that some guys who had been developing alternative management software might no longer be in this forum.

Are you able to suggest any pointers to JCN  or maybe suggests relevant treads in this forum?

Link to post
Share on other sites

I see that not all the commands is available in the document like  "QPRIO"

You can also try the following forum and ask there.  Pi devolopment for the Axpert and Infini.  tinkercity.co.za 

I dont have a Infini to test. You can ask there, some of the people have Infini and can maybe test and help

Link to post
Share on other sites
On ‎28‎.‎7‎.‎2016‎. at 8:58 PM, jcn said:

Hello Hristo, thanks for your info.

I am not sure if I will take the risk of flashing it with another firmware yet - if possible I would like to try to send commands directly to the inverter. But I wait for a little more help on that one :-)

But maybe if all else fails.
Could you describe more in detail what you have done and what the result was.

Thanks :-)

Hi jcn

You dont instal new firmware only see whichis version. of DSP and MCU and time.

 

Main CPU processor version: 3.10 and
Secondary CPU processor version: 0.31 has diferent type of software and this software call DSP and MCU.Every DSP and MCU has time of version bilding.

 

 

That mean that you have diferent procesor  because you have newer device but this procesor must work with firmweare of 2014 7 mounth.I have been  problem with DC bus 02  wrong.

I cant work with batery.I wrote in voltronic but I get answer how I must buy another charger modul.But interesting thing has been that I must work with batery only if I have load more of 700w.Than I put new reflesh tool and i see that I have firmware in the 2013 years.In this fw (DSP and MCU) 4 mounth 2013 only good thing is the fan work if is PV more of 500w.

In the newer FW(2014-7) fan work non stop.

Interesting thing that i spoke with service man in Croatia.He says that is FW in 2012 fan work non stop .

I dont know every details of fw but I know that now device work ok.

 

But I dont Undestand how you dont have in device control my power menagment.

I instal now SP 1,10 in the second Computer without device and i have device contol.

 

Do you have my power menagment if is device disconet?

 

 

 

 

Link to post
Share on other sites

Hi Hristo - yes, that is exactly what happens; without the inverter connected, I see the MyPower Management menu point. But when I connect the inverter: the menu point goes away...

@MaurizioZA: your efforts are MUCH appreciated!!  Send my appologies to your wife and family!! :-) :-)

I will try to look into the commands and see if they work with my inverter. Hopefully they do!
I can live with just the command line option -as long as I can control the inverter and be sure what it does .

I have also contacted Voltronic from the beginning, but they are not very informative - they just want to sell new units :-)
But I still hope that they might help with the problem. Selling hybrid inverters where you can not control the power flow just doesn't make much sence...

Thank you all for your help -I will let you know the results of the command line tests asap.

Greetings from the North.

Jens Christian

Link to post
Share on other sites

Hello everybody -good news! :-)

Yesterday Voltronic came back to me with a firmware update file for the 3kW hybrid inverter!

And it works!! :-)

They will not guarantee that all setup options in the new software is available in my older inverter, of course. But I can enter the MyPower Management menu now and setup for GridTie with Backup II as I need to. So perfect!!

Will anybody have interest in the firmware update files let me know.
Attached screendumps of the before-and-after version numbers.

Only one issue now - the fans are on 24/7 in the inverter. No matter the load or PV input, the fans are running.
I remember I read about that in another post and I will try to find it again. 
-if anybody has the solution on hand, I would be greatfull to hear it ! :-)  

Thank you for your help everybody!

Greetings from Denmark
Jens Christian Nørtoft Bækgaard

Version_before_after.docx

Link to post
Share on other sites
On 04.08.2016. at 9:17 AM, jcn said:

Hello everybody -good news! :-)

Yesterday Voltronic came back to me with a firmware update file for the 3kW hybrid inverter!

And it works!! :-)

They will not guarantee that all setup options in the new software is available in my older inverter, of course. But I can enter the MyPower Management menu now and setup for GridTie with Backup II as I need to. So perfect!!

Will anybody have interest in the firmware update files let me know.
Attached screendumps of the before-and-after version numbers.

Only one issue now - the fans are on 24/7 in the inverter. No matter the load or PV input, the fans are running.
I remember I read about that in another post and I will try to find it again. 
-if anybody has the solution on hand, I would be greatfull to hear it ! :-)  

Thank you for your help everybody!

Greetings from Denmark
Jens Christian Nørtoft Bækgaard

Version_before_after.docx

Super.

 

Interesting,you have newer device but older fw.

I say you that you solve problem with new fw.

I spent to many time for enayble my device.

Interesting how wrong fw doing to many problem,and how Voltronic made this device.

Now know thah all fw before 2014 is problematic.

 

You have DSP 13,03,13

               MCU 13,03,13.

I have DSP 13,07,04

MCU 13,07,04.

This two fw is very problematic.

 

Now I have  DSP i MCU 14,05,30,,,14,06,04 everything works and you have

 

DSP 15,09,24,,MCU 15,11,04

 

About fan,I thing that is Voltronic solve this problem,in that is manual write that is Device to many noise and this it.

The first interval fan is when PV work 0-1500w,second is if is higher on 1500w.

 

I interesting for new fw,

Please sent me.

 

Thanks

 

 

 

 

 

 

Link to post
Share on other sites
1 hour ago, jcn said:

Hi Hristo

Attached find the firmware files.
You need to connect via RS232 serial interface.
The file contains both update software and "how-to-guide".

In regards to the fan noise, I think I will replace the fans to low-noise versions and let them be "on" all the time.

Best regards

Jens Christian, Denmark

firmware for 96121306100022.rar

Interesting,

You instal fw for infinisolar3kw+.

This is same fw which have 3kw+.

 

For now I stay in FW in 2014 years,everything work.

 

 

Thanks  

 

 

 

 

 

Link to post
Share on other sites
  • 8 months later...
  • 1 year later...
On 2015/05/05 at 1:10 PM, Wetkit said:

Hi Greg,

 

I can confirm the power draw, even with no load. My Efenery meter say about 200W with no load connected on the invertor.

 

Your battery voltages looks fine according to Trojan specs.

Yes, the Infini only goes up to 58V max :(

I have not seen a setting for Equilising the battries :(

 

On the parameter settings, all is looking as per standard, except the  "Feeding grid power callibration:".

Was this standard at ZERO or was it 100w and you changed it?

I think this setting gave me issues on my pre-paid meter when I set it to ZERO. Currently it is back at 100w.

 

Regarding your yellow circle question....

I'm also debating that one.

For now I have it set at 0.5 Amps for 60Min. This means if the battery current is 0.5Amp or less, for 60min, the charger will disconnect.

The way you have the last variable, the charger will only re-connect if the battery voltage reach 52.2V.

I have mine set to 50V, but that is another story...

 

Regarding your question on Off-grid vs Gridtie+backup...

In off-grid mode you cycling the battery way more than 3 times during the day. This will result in shortned battery life.

PV power and grid power can not be combined.

 

In Gridtie+Backup mode the battries is only ever used if grid power fails. This gives your battries a longer life.

Also PV power and Grid power is combined to supply the required output if PV power is too low to supply the load.

Hi WetKit,

In your reply above you mentioned that PV power and grid cannot be combined in off-grid mode (see red text above).

I have Infini V 5KW inverter.  Its specs say that it can combine PV and Grid in SUB mode (irrespective of off-grid or grid-tie mode).  Can you confirm?

Link to post
Share on other sites
On 2016/08/10 at 1:21 PM, jcn said:

Hi Hristo

Attached find the firmware files.
You need to connect via RS232 serial interface.
The file contains both update software and "how-to-guide".

In regards to the fan noise, I think I will replace the fans to low-noise versions and let them be "on" all the time.

Best regards

Jens Christian, Denmark

firmware for 96121306100022.rar

Hi,

Thanks for the firmware. Can you send me the password for the rar file? Also, how do I know which firmware I am running. Below is my device information page. I have an Infini 3KW +

image.png.2a6aeda0dedb76d86e0ddd88550afe3c.png

Link to post
Share on other sites
  • 5 months later...
  • 1 year later...
On 2016/03/13 at 1:14 PM, Kwagga said:

Hi Ivan

I did not have the Solarpower Factory password

Did have an USB to RS232 converter cable

I also had an problem with the 50.1 HZ so i changed the freq and the batt voltage calibration  with the RS 232 AccessPort  program.

Check page 21 of the RS 232 protocol (Set grid output frequency high loss point)

Hope this help

 

 

RS232 Protocol.pdf

AccessPort_and_SOP_battery_calibration(1).rar

Can you share rs232 protocol and access port program again because these are available on the blog

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...