Jump to content

Goodwe 5kW GW5048D-ES Inverter Not Charging


Nevan

Recommended Posts

Hi everyone. The grid dropped its Neutral wire last week, so only had the Earth Wire acting as the return over 200m.

The voltage was fluctuating between 190V and 260V and the inverter overcharged four new 160AH Lead Acid Batteries ($3600)

After the grid was repaired the inverter no longer charges the batteries. The voltage is there but no current.

The inverter will also not use the batteries for input power supply.

Ive tried all the Modes, full resets - tried everything, but no change.

Did a reset today and the battery SOC jumped from 33% to 80% for three hours then back to 30% - all with no current output.

When I bought the inverter Goodwe said it was good for Lead Acid, but they have now changed their position and stated it doesnt support PB.

And of course will now no longer respond to my emails.

Are there any ideas out there?

... Nev

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...