Jump to content

pv to inverter contact lost? SOLVED


Gabriël
 Share

Recommended Posts

I TESTED THE FUSE, IT IS BLOWN - QUESTION WHY? REMAINS. PARDON MY ELECTRONIC IGNORANCE!!

I ATTACH PICS OF THE FUSE... IS IT THE RIGHT ONE I WONDER? :huh:

suddenly i got this picture on my icc dash [system now disconnected]:

5ab2240637e0d_pvdown.JPG.e97d7f5cab39503ba78d014dae16b47f.JPG

i checked this fuse which is between inverter and pv and it looks ok and the readout on the axpert 5kv also indicates no comms with the pv:

5ab22483e4ac4_lostpvcontact.thumb.jpg.31ae185bc1e8127b2aa13c247585fa57.jpg

1st i'll try replacing the fuse, maybe it has blown but doesn't show, but from there i'm a bit lost

any ideas?

IMG_20180321_140812.jpg

IMG_20180321_140834.jpg

IMG_20180321_140746.jpg

Link to comment
Share on other sites

2 hours ago, gabriel said:

checked this fuse

How did you check it? It's a ceramic fuse filled with a sand-like substance specifically to extinguish the arc. The only way to check it is to test that it isn't open circuit, eg use a DMM and check the resistance or one of those automotive test lights and a power source. You cannot tell by visual inspection.

Link to comment
Share on other sites

3 hours ago, gabriel said:

I ATTACH PICS OF THE FUSE... IS IT THE RIGHT ONE I WONDER? :huh:

It's a good fuse. Bussmann makes good stuff. It's rated at 1000VDC, which is total overkill. Replace the fuse and you will be good.

Perhaps just do the math again to make sure you weren't actually over 20 ampere. Fuses sometimes blow for reasons other than overcurrent.

Link to comment
Share on other sites

4 minutes ago, plonkster said:

make sure you weren't actually over 20 ampere

how would i do that?

then there is the other matter. on icc i had erratic readings regarding inverter temperature and load etc prior to the fuse going - i mean on average the readings were what they should be but then they would have erratic up/down spikes at random intervals - could that in any way have caused the fuse to the pv to go?

Link to comment
Share on other sites

4 minutes ago, gabriel said:

how would i do that?

Take the Isc (short circuit current) rating of your panels and multiply by the number of strings.

For example, if you have the typical setup of 250W/275W 60-cell panels arranged in two strings, three panels in each, then the Isc is usually around 8 amps and two strings would give you 16 amps (which is good) while 3 strings would give you 24 (which is bad).

In my experience, a 20A fuse can run somewhat hot when operating close to its rated capacity, and can over time deteriorate and blow.

Link to comment
Share on other sites

On 2018/03/21 at 2:50 PM, plonkster said:

Take the Isc (short circuit current) rating of your panels and multiply by the number of strings.

For example, if you have the typical setup of 250W/275W 60-cell panels arranged in two strings, three panels in each, then the Isc is usually around 8 amps and two strings would give you 16 amps (which is good) while 3 strings would give you 24 (which is bad).

In my experience, a 20A fuse can run somewhat hot when operating close to its rated capacity, and can over time deteriorate and blow.

Looking at his signature, I'd say the the fuse was a tad bit small for his setup. A 25A fuse might be a better bet for his 17.5A string. 

Why did it blow? Sometimes your panels can produce more electricity than rated 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...