Jump to content
Thank you for the great forum, Safe Driving over the weekend. Sincerely Jason
wolf

Axpert error code 90

Recommended Posts

Hi, Need assistance

Have an error code 90 on an Axpert MKS 5KVA inverter. Tried searching but could not find error code 90 anywhere.

Need to know what it means and how to fix it.  Have shut down and restarted the inverter with all loads and PV off. The same error remains.

Share this post


Link to post
Share on other sites
On 28/03/2018 at 11:02 AM, wolf said:

Have an error code 90 on an Axpert MKS 5KVA inverter.

Ah, interesting.

Quote

Tried searching but could not find error code 90 anywhere.

[ Edit: I meant to say: there are plenty of things that are not documented by mistake. But this one might be one that is very deliberately not documented. ]

This code is new in main firmware version 73.00. It's set in a function that is only called my some mysterious code that is new in 73.00. My initial guess is that this code is designed to fool firmware counterfeits into producing this error, possibly an hour after power on. [ Edit : actually, it's probably 1440 hours, or 60 days. If my theory is right. ] 

Either it's working as intended, in which case it's discovered that your firmware is fake. I note that Weber and my "patched official firmware" is actual official firmware with some patches, so it doesn't affect this checking, as far as I know.

Or this error 90 fake firmware detection is not working correctly, and is identifying your firmware as fake when it is not (a false positive, if you like).

The third possibility is that I've misidentified the purpose of this error.

So first up: what's the "pedigree" of your machine? Was it bought from one of the official rebranders like Mecer, or from a less well known source? Was it perhaps sourced directly from China?

Edited by Coulomb
1440 hours, not one

Share this post


Link to post
Share on other sites

Thanks for the quick response. Bought it in March 2015 from an online store in South Africa(bonanzatech.co.za). Do not currently have access to it at the moment so cannot give you the version number.

But I believe I did install the firmware version 73.00 which I downloaded from one of the forum sites. Updated this about a 2 months ago.

I suppose the first step will be to restore the firmware to something more suitable to its age. Will update to this post once I can check the version number.

These are the firmware files I currently have.

4048MS 73.00 (Installed at present)

PIP-MS_5K72.40

dsp_LC1_72.70c

System:

Axpert MKS 5KVA Inverter(48V)

3 Banks of Trojan T105

9 x 240W (3 strings of 3)

Share this post


Link to post
Share on other sites
On 2018/03/29 at 1:05 AM, wolf said:

Thanks for the quick response. Bought it in March 2015 from an online store in South Africa(bonanzatech.co.za). Do not currently have access to it at the moment so cannot give you the version number.

But I believe I did install the firmware version 73.00 which I downloaded from one of the forum sites. Updated this about a 2 months ago.

I suppose the first step will be to restore the firmware to something more suitable to its age. Will update to this post once I can check the version number.

These are the firmware files I currently have.

4048MS 73.00 (Installed at present)

PIP-MS_5K72.40

dsp_LC1_72.70c

System:

Axpert MKS 5KVA Inverter(48V)

3 Banks of Trojan T105

9 x 240W (3 strings of 3)

Bonanzatech generally sells Mustek stuff, so it's probably the firmware that's the culprit

Share this post


Link to post
Share on other sites

Thank you, I thought so too thanks to the reply from Coulomb. Will try and downgrade the firmware as soon as I get access to the inverter again.

Share this post


Link to post
Share on other sites
On 29/03/2018 at 9:05 AM, wolf said:

But I believe I did install the firmware version 73.00 which I downloaded from one of the forum sites. Updated this about a 2 months ago.

Ah. I see a potential problem here. For now, it looks like firmware version 73.00 (as factory supplied, but also patched firmware 73.00a) can't be used with certain older hardware. It's impossible (for me) to say how old the machine has to be before it has this problem. The problem may or may not be able to be addressed in a future patched firmware.

Quote

I suppose the first step will be to restore the firmware to something more suitable to its age.

Yes.

Quote

These are the firmware files I currently have.

4048MS 73.00 (Installed at present)

PIP-MS_5K72.40

dsp_LC1_72.70c

I'd go with dsp_LC1_72.70c for now.

Share this post


Link to post
Share on other sites

Hi Wolf,

My PIP4048MS I bought some years ago from MPPSolar on EBay has just came up with error 90 some time during day time.  Did you find a solution?

I am currently using Coulomb's Beta Version of Patched Firmware 73.00a.

Maybe upgrading to 73.00B will fix this problem.

UPDATE: I just updated the firmware to 73.00b and the error 90 disappeared. The inverter works but the solar charge controlller does not. WTF.

eroor 90.jpg

Edited by lopezjm2001
SCC no longer works.

Share this post


Link to post
Share on other sites

lopezjm2001

On 3/28/2018 at 4:24 AM, Coulomb said:

My initial guess is that this code is designed to fool firmware counterfeits into producing this error, possibly an hour after power on. [ Edit : actually, it's probably 1440 hours, or 60 days. If my theory is right. ] 

The error only shows up long after the update.

 

On 3/31/2018 at 3:44 PM, Coulomb said:

Actually, now you have an additional choice; Weber and I have just released 73.00b to fix this problem.

I will be going for 73.00b

 

I have not updated my firmware yet so cannot give any feedback.

 

 

Share this post


Link to post
Share on other sites
7 hours ago, wolf said:

lopezjm2001

The error only shows up long after the update.

OK. But my inverter works with firmware update 73.0b but the SCC section no longer works. :(

WatchPower is showing Secondary CPU Version  00000.00. - not good.

 

Capture.PNG

Share this post


Link to post
Share on other sites
1 hour ago, lopezjm2001 said:

WatchPower is showing Secondary CPU Version  00000.00. - not good.

That will happen any time that the SCC isn't getting PV power, either at night or if the PV isolator is off. The SCC processor is powered only from the PV input, not from the battery or AC input.

Share this post


Link to post
Share on other sites
On ‎29‎/‎04‎/‎2018 at 1:11 PM, Coulomb said:

That will happen any time that the SCC isn't getting PV power, either at night or if the PV isolator is off. The SCC processor is powered only from the PV input, not from the battery or AC input.

After trying to flash the SCC firmware unsuccessfully I checked the cables and actually read the markings on the PCBs and realised I had the two 4 pin plugs swapped between the LED and the SCC. All is working well now. Thanks. :wacko: So I was actually trying to flash the LCD, doh...

Share this post


Link to post
Share on other sites

Well, that video piqued my interest. @CHOCHUENO, since I don't speak Spanish, was this a specific tool provided just for you with your machine's serial number?

Was this necessary because your EEPROM lost its contents somehow? Your machine seems like it's a genuine MPPSolar branded hybrid inverter made by Voltronic Power. So in the ordinary course of events, I would assume that error 90 should never occur.

 

 

Share this post


Link to post
Share on other sites
21 hours ago, manee_man said:

i try instal firmware but firmware not instaled compot fail

Are you saying that you have a firmware update file from your supplier, for factory firmware version 11.01 or a later version in the 11.xx series?

If not, PLEASE don't attempt to update the firmware with something from a different model; it is known that you can brick your inverter that way.

Share this post


Link to post
Share on other sites
54 minutes ago, manee_man said:

MR: chochueno not send this solution file

My understanding is that the applications with names ending in "tools" are specific to a particular machine. I don't know for certain, but I suspect that if the existing serial number doesn't match, then using this tool will simply result in an error message, and error 90 will persist.

So Mr Chochueno or any other owner can't help you with the "solution file"; it has to be custom made for you by someone at Voltronic Power, and they will only do it at the request of your supplier, who will need to verify that your machine was sold by them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Topics

Contact Us - Power Forum South Africa

×
×
  • Create New...