Jump to content

Voltronics Infinisolar Super 4kw problems


Recommended Posts

Hi all. I am hoping you can help me after 2 very frustrating weeks of trying to resolve issues I am having with a system setup. I hope I am able to explain this properly. 

I have 3 strings of 12 Amerisolar 265 modules. Each string is connected to a Infinisolar Super 4kw inverter. As per the manual, the modules are not earthed. 

I have paralleled the 3 inverters. They are all programmed in off grid mode 1. 

I have paralleled 6 2.5kwh coslight lithium ion batteries on a busbar to give me a 15kwh pack with 50v and 300a. 

The system works well for a few hours and then one of the inverters (not always the same one) trips. First shows error 12, current leakage exceeds maximum and then immediately error 36, dont connect grid to output terminal. 

Incoming grid from utility has only L and N which go to main utility fuse box which then has a earthing to ground. L and N then go to utility meter. Once they exit the meter I have run them approximately 100m to an ACDB next to the inverters where they are each split into 3 and are connected to the L and N terminals of the ac input terminal of each inverter. The earth terminal of each ac input terminal is taken to a nearby earth pit. 

The ac output L and N from each inverter are taken to an accb and combined to single L and N which travel back to the meter box where they are connected to the house load. The house load is earthed at the same place as the incoming grid. The earth at each ac output terminal of the inverters is taken to the same earth pit as the ac input earths. 

I have checked for current leakage in the house itself and found some issues which have been rectified. I have tested the modules and they are not leaking current. I have checked the insulation of the ac grid to inverters cables and ac output to load cables and all are fine. 

The body of the inverters have been earthed as well. 

Voltronics are not helping at all with my problem and are not willing to come on a call and insist on keeping all communication to emails which they rarely answer and if they do it is several days later and of little help. 

Has anyone else faced the current leakage issues? I am hoping that once I sort out this issue then fault 36 will disappear as it only appears when fault 12 appears. 

Thank you in advance for any advice you can pass on. 

 

 

Link to comment
Share on other sites

Hi Rups, Welcome to the forum. 

6 hours ago, Rups said:

As per the manual, the modules are not earthed. 

We had a small discussion about this last week. The way we understand it, is that you should not ground the Positive or negative wires of the PV modules, but you should ground the frame of the panel. 

6 hours ago, Rups said:

First shows error 12, current leakage exceeds maximum and then immediately error 36, dont connect grid to output terminal. 

I have two of these units n parallel and was faced with the same errors directly after installation. The 1 unit would give the error, I would restart it and a couple of days later the other one did the same, no specific pattern , but they made turns tripping . I received the latest firmware from the supplier and loaded it. That solved the issue.  

That was more than a year ago, and i dont know if there is a newer version available. I will e-mail my supplier and find out, if not i will upload the version i have and you can try it. 

6 hours ago, Rups said:

Has anyone else faced the current leakage issues?

At first i though I might have an issue with leakage , but after inspecting all wiring, I realized I was on the wrong track and moved my attention to the units. 

Link to comment
Share on other sites

Thank you very much Jaco for coming back to me. 

I was wondering the same on the module earthing. I think I will try earthing the frame. 

Look forward to hearing from you regarding the firmware. 

Really has been a painful few weeks. 

 

Regards 

Link to comment
Share on other sites

1 hour ago, Rups said:

Look forward to hearing from you regarding the firmware.

Rups, Please give me a few hours. There is new firmware, including a "leakage" firmware  , the supplier I had in mind is very reluctant to hand it out. They request the serial numbers of all three your units , they will then contact Voltronic to  confirm that the hardware in your inverters are indeed compatible with the firmware and only then they will give us the firmware under condition that I don't make it available on a public platform. 

If you want to go the long route please PM me the serial numbers.

Another supplier has the firmware, but can't mail it because of the size of the file. They are 500KM from me, so a friend of mine just around the corner from them,  is on his way to them with a flash drive to go collect it, He will then upload it to dropbox. Will let you know when I have a copy in hand.  

Link to comment
Share on other sites

21 hours ago, Rups said:

The earth terminal of each ac input terminal is taken to a nearby earth pit. 

I am not familiar with the geographical layout of your system but you appear  to have two earth bonds which is a bad idea for two reasons.

  1. It makes troubleshooting earth leakage problems nearly impossible (and is not according to spec)
  2. If you have a lightning strike nearby and a ground voltage gradient is set up then lightning current may travel up your bonded cabling and travel from on earth to the other as your cabling's resistance is lower than that of the ground.
Link to comment
Share on other sites

On 2018/09/11 at 7:16 AM, Rups said:

Look forward to hearing from you regarding the firmware. 

 

On 2018/09/11 at 8:33 AM, Jaco de Jongh said:

Rups, Please give me a few hours.

HI Rups, I apologise for the delay, misunderstanding between me and friend. I am waiting for link to download file and he is waiting for me to accept a contact request in cloud so that he can share the file internally and not with an external link. He will share as soon as he steps into the office. Will definitely have the firmware today.   

Link to comment
Share on other sites

Hi Rups

Please read this first. This post will inform you of the problems on the DC side that requires a replacement board to fix the issue. 

The wait for the firmware was a total waste, the version they send me is exactly the same as the version I allready have for my own units as well as a version that is in the Forum's download section... 

The Firmware can be downloaded Here .

Advice on re-flashing . 

  1. Use serial cable if possible. 
  2. what ever you do, don't let the device you use to flash the firmware loose power. If you loose power during this process, you might brick your device. 
  3. Switch all units off, switch only one on and flash the firmware. When done switch him off and do the next one. 
  4. There are two files , if I remember correctly "Master" and "Slave" , each machine must be loaded with both as every unit can be master or slave. That means you have to repeat the action for a second time with a different file...
  5. If you feel you need help I can try and assist via Any-desk or Teamview.  

 

Link to comment
Share on other sites

Hi Jaco. Thanks for your comments and for the firmware. Voltronics finally replied to me and sent over the firmware as well on Tuesday. However it took me a couple of days to find an old pc with serial ports.

 I unparalleled the inverters today and installed both master and slave firmware on all three inverters today. All seemed ok until I tried to parallel them again. On one of the inverters I am now getting fault 80, CAN fault every time I try to parallel it with the other 2. Anyone else had this fault before?

 I have again emailed voltronics but doubt they will revert any time soon. I don’t understand why they are not willing to provide voice support and why each revert takes them days and is light on solutions and mostly just repeats what is already in the manual. Never experienced this with any other inverter manufacturers. 

On a separate note I read the comments regarding the DC boards. 2 inverters have become faulty during this project (I initially had 6 in stock and now only have one left).  Both show fault 3 now and wont work. I have again written to voltronics asking why the inverters i have did not have the new dc boards sent over. Not sure i will hear back from them though. Let’s see.

thanks again for your help on this 

Link to comment
Share on other sites

Hi Rups,

contrary to the InfiniSolar Plus 5K and InfiniSolar Plus 10K 3Phase, the model InfiniSolar Super 4K has a different internal arrangement. Long story short, this is the most problematic product from the InfiniSolar's Hybrid inverters portfolio.

For example, the neutral-in and neutral-out terminals of the unit cannot be wired together.  Since somewhere in the main DB, the PE and N are wired together, that implies that you cannot connect neutral-out from the inverter with the earth too. Normally, everybody will say something like "of course, I'm sure that I have N and PE separated on the output", but the reality is that in a number of installations there IS an interconnection between the two somewhere down the line. Or, there's a non-compliant appliance in the house, that has these two interconnected.

When the terminals are interconnected, sooner or later, the InifiSolar Super 4K will fail.

Just check with the multimeter, if you have neutral-out + PE interconnected down the line. If you do, this might be the cause why so many units failed from your stock.

 

Link to comment
Share on other sites

  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...