Jump to content
Thank you for the great forum, Safe Driving over the weekend. Sincerely Jason
Querobin

InfiniSolar Super 4KW

Recommended Posts

The inverter is not working, I tried to supply with dc and it doesn't turn on. I tried to supply with AC and it does turn on. What could be the possible fault? And what would be the solution?

Share this post


Link to post
Share on other sites
10 hours ago, plonkster said:

He's not very active here anymore

Sorry, seldom see my home before 10 at night. Was waiting for some settings to take affect on a cold room when i saw this post on my phone. Just arrived home,so i will try and answer quickly. 

11 hours ago, Querobin said:

I tried to supply with dc and it doesn't turn on. I tried to supply with AC and it does turn on.

I assume this unit was working and suddenly stopped working. 

11 hours ago, Querobin said:

What could be the possible fault?

Sadly most of them were sold with a faulty DC board. My first failures were exactly like your explanation. Ac brought them on, but dc not.

11 hours ago, Querobin said:

And what would be the solution?

Have the DC board replaced. Please ask for a replacement board that was manufactured after FEB 2018. There is still some of the older boards floating around. Replacing with those will result in a failure in the future again. 

Good luck. 

Share this post


Link to post
Share on other sites
On 2019/01/27 at 3:41 AM, Jaco de Jongh said:

Sorry, seldom see my home before 10 at night. Was waiting for some settings to take affect on a cold room when i saw this post on my phone. Just arrived home,so i will try and answer quickly. 

I assume this unit was working and suddenly stopped working. 

Sadly most of them were sold with a faulty DC board. My first failures were exactly like your explanation. Ac brought them on, but dc not.

Have the DC board replaced. Please ask for a replacement board that was manufactured after FEB 2018. There is still some of the older boards floating around. Replacing with those will result in a failure in the future again. 

Good luck. 

Hi I'm back,

 

I was able to replace the dc board and there are warnings flashing. Please see picture and I hope you can help me figure this out. The error is number 10 and 14.

Appreciate the hand.

0.PNG

Share this post


Link to post
Share on other sites

"EPO is open" means that the little green socket on the bottom side of the inverter is empty. There should be a green 2 pole plug with no wires in this socket. This plug is basically a jumper.

When installed in the office buildings this plug must be removed and instead a Central Stop button for the firefighters goes there.

Other error (14) can be ignored, if the inverter is running okay. It works correctly only with FLA batteries. With Lithium, these under-voltage errors are pretty common. To get rid of them one has to lower the low-voltage cut-off value.

Edited by Youda

Share this post


Link to post
Share on other sites

hi guysh i am commenting on an old post but its Infini Solar 10kw related.

2x in parallel.

1 inverter has Error 60 and the other is OK.
I know its got to do with feedback power but struggling to find the cause.
Please assist?

Share this post


Link to post
Share on other sites
On 2019/05/27 at 4:35 PM, Youda said:

"EPO is open" means that the little green socket on the bottom side of the inverter is empty. There should be a green 2 pole plug with no wires in this socket. This plug is basically a jumper.

When installed in the office buildings this plug must be removed and instead a Central Stop button for the firefighters goes there.

Other error (14) can be ignored, if the inverter is running okay. It works correctly only with FLA batteries. With Lithium, these under-voltage errors are pretty common. To get rid of them one has to lower the low-voltage cut-off value.

Thanks, appreciate it.

Share this post


Link to post
Share on other sites

@Jaco de Jongh 3 inverters, infini super 4k to be repair, ordered 3 dc board which we waited for 6 weeks, first inverter was working with the first dc board with supplies of AC, battery and PV, while the 2nd inverter with the 2nd dc board was not successful, the new dc board was destroyed, burnt upon supplying AC from the grid which means (transistor burnt out). 3rd inverter, upon replacing the dc and supplying with AC, there was a spark so we turned off immediately, removed the dc board and tried testing to the first inverter which is working fine and the dc board (3rd) is also working fine. From this actions, could you please help me with your diagnosis if what would be the problem.

I really appreciate the help.

 

Thanks,

Querobin

Share this post


Link to post
Share on other sites
6 minutes ago, Querobin said:

From this actions, could you please help me with your diagnosis if what would be the problem.

I really appreciate the help.

The last 2 times my units blew, both the AC and DC boards popped. I guess that is also the case on two of your units.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Topics

Contact Us - Power Forum South Africa

×
×
  • Create New...