Jump to content

Axpert King Inverter Firmware


Recommended Posts

  • Replies 261
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi @Coulomb @weber I see that you've done a lot of work for the PV community, namely when comes to improving firmware of a numerous Voltronic Axpert inverters. I noticed, that you're giving your

@Youda You sir are a gentleman!  Maybe a gofundme page? I am sure others share your sentiments. 

Good morning @Coulomb yes, of course, the sponsorship offer i still valid Personally, I have InfiniSolar in my setup, but I have a past experience with an Axpert too and I know that it's a

Posted Images

Hi @Coulomb 

How was it done with 

“This is the one I bought second time round. And it worked perfectly. 

https://www.takealot.com/trendnet-usb-to-serial-converter/PLID29271821

this cable? 
The cable I got in the box is a RS232 on one side and a female serial on the other, can’t even plug it into my laptop as the laptop has female as well I believe, will check it again though.

Will also check The manual again if I can do it via the USB port on the inverter.

Link to post
Share on other sites
52 minutes ago, Wilfred said:

How was it done with ... this cable? 

That adapter should plug into your computer (the USB end), and the other end should plug into the cable you got with your inverter. The other end of that should plug into the "RS-232" port of the inverter (it's actually an RJ-45 socket). Don't try to use any RJ-45 connector on your computer; that will be an ethernet port (not suitable for Axpert inverters).

Link to post
Share on other sites
9 hours ago, Wilfred said:

Hi @Coulomb 

How was it done with 

“This is the one I bought second time round. And it worked perfectly. 

https://www.takealot.com/trendnet-usb-to-serial-converter/PLID29271821

this cable? 
The cable I got in the box is a RS232 on one side and a female serial on the other, can’t even plug it into my laptop as the laptop has female as well I believe, will check it again though.

Will also check The manual again if I can do it via the USB port on the inverter.

 

8 hours ago, Coulomb said:

That adapter should plug into your computer (the USB end), and the other end should plug into the cable you got with your inverter. The other end of that should plug into the "RS-232" port of the inverter (it's actually an RJ-45 socket). Don't try to use any RJ-45 connector on your computer; that will be an ethernet port (not suitable for Axpert inverters).

just as @Coulomb said the rs-232 cable that came with the axpert inverter connects to the serial usb cable you will purchase (see pics below)

I finally got to update both the Main firmware and screen firmware this morning. There was a little bit of scare though when I was updating the screen firmware.

The inverter screen went blank completely and I panicked. I finally re-pluged  the cable after I had removed it and shut down the batteries, started the flash all over again, when it completed 100%, the inverter screen came back on

 

 

2223333333.jpg

Link to post
Share on other sites
5 hours ago, Coulomb said:

I presume that is a USB On The Go cable. I had not heard of one of these till now.

Would you care to explain a little more fully what is needed and generally how it works?

I put the firmware on a USB drive, plugged the OTG cable into the port on the inverter, then plugged in the USB drive into the other end of the OTG. 

 

Then went into the menu item specified in the inverter manual for updating firmware by USB (can't remember now exactly where that is). Once I confirmed my selection the rest just happened. Was quite painless.

Link to post
Share on other sites

The Axpert King manual page 23 (PDF page 25), suggests to me that you can upgrade the inverter firmware, simply by having the files on a USB stick (flash drive) plugged into the USB port of the display unit. No need for any kind of serial comms adapter or cable. I can't try this because I don't have an Axpert King. Has anyone tried this?

http://www.mppsolar.com/manual/PIP-MK (PF1.0)/PIP-MK manual-20190717.pdf

Edited by weber
Link to post
Share on other sites

Ah! I think I get it now. Despite the manual saying "Please insert USB disk into USB port", you can't actually do that because there is no type-A USB port on the display unit, hence the need for the OTG cable.

What kind of B port is on the display unit? It looks like a micro-B. If so, then the OTG cable or adapter would be like this.

Edited by weber
Changed "mini-B" to "micro-B".
Link to post
Share on other sites
5 hours ago, weber said:

Ah! I think I get it now. Despite the manual saying "Please insert USB disk into USB port", you can't actually do that because there is no type-A USB port on the display unit, hence the need for the OTG cable.

What kind of B port is on the display unit? It looks like a micro-B. If so, then the OTG cable or adapter would be like this.

Exactly right. Sorry I should have been clear on that in my previous post.

Link to post
Share on other sites
  • 3 weeks later...
On 2019/12/21 at 4:16 PM, MJS said:

not sure what you mean abut the screen firmware version.

When I press the key next to the enter key it shows U01 with the fault sign

I managed to get the communication going and upgradeing is running again. Will report later.

 

Hi @MJS

I just got 3 of these inverters.  I flashed two of them to 71.86 no problem.  Third stopped at about 10% with error 32. 

You say "I managed to get the communication going" - how did you do that?  Mine simply goes to blank screen with "32" as soon as the boot count down is complete.  Power cycle does not help.

 

Link to post
Share on other sites
8 hours ago, Coulomb said:

So did this one come good, for example by restarting the reflash process?

@Coulomb

I am afraid not.  After power cycle it now has the 32 fault code on screen (nothing else).  The fans run at 100%.  No button seem to work, and the updater says "Failed to open comms 1" (The serial adapter and cable is fine - I can communicate with the other units.)

I have swapped the comms/display unit with one from another inverter and it makes no difference - the fault is in the inverter itself.

One minor point: the power button seems to work. (Press when off: unit powers on.  Press when on (fans running): unit does not switch off, but after reboot it is off.)

Not sure if there is anything to do?  I can return it to Mecer I guess - surely they will be able to reflash the board directly?  I had to attempt the firmware update as the 3 units I got from them did not all have the same version (1 x 71.50, 2 x 71.80). Parallel operation requires all 3 to have the same version.

Any assistance / advice much appreciated.

Link to post
Share on other sites

OK, I have managed to fix it.

Essentially, the USB OTG firmware update still worked, exactly as described in the manual.

1. Copy dsp.hex to FAT32 formatted USB.

2. Connect with OTG cable to USB port.

3. Start USB menu by holding down top left button for 3 secs.

4. Select Upgrade firmware, confirm, when it says "UPG YES" it takes about 10 minutes.

All 3 now on 71.86😀

Link to post
Share on other sites
On 2020/01/17 at 4:15 PM, Calvin said:

Hi @MJS

I just got 3 of these inverters.  I flashed two of them to 71.86 no problem.  Third stopped at about 10% with error 32. 

You say "I managed to get the communication going" - how did you do that?  Mine simply goes to blank screen with "32" as soon as the boot count down is complete.  Power cycle does not help.

 

I am afraid I was absent for a while so only see this today. Is there a notification process so that I do not miss messages like yours?

The issue with comms in my case was my USB - RS232 adapter. I believe baud rates didn't match. I have a similar issue with Watchpower on the laptop.

Instead USB-RS232 I used an old laptop with build in RS232 and the comms was ok.

Link to post
Share on other sites
On 2020/01/26 at 5:01 PM, MJS said:

Is there a notification process so that I do not miss messages like yours?

I believe that you can subscribe to a topic, and get email messages when there are new posts.

Quote

The issue with comms in my case was my USB - RS232 adapter. I believe baud rates didn't match.

The communications in the cable itself is USB; the serial port is virtual. So you can and must set the bit rate at the computer; it's not fixed by the hardware of the USB to serial adapter. There are odd reasons why some USB to serial adapters don't work, but I don't believe that a mismatched bit rate is one of them.

Edited by Coulomb
" why USB to serial" → " why some USB to serial"
Link to post
Share on other sites
  • 2 weeks later...

Hi All... Might be a silly question... Will this firmware work on the King 3KVA model too?\

In ICC it is reporting my CPU 1 is on version 51.50 and CPU 2 is on Version 1.10... I am presuming that is the unit vs the display firmware... Is it okay to go directly to the new version?

Thanks in advance

Link to post
Share on other sites
4 hours ago, Jay-Dee said:

Hi All... Might be a silly question... Will this firmware work on the King 3KVA model too?

No. The King 3 kVA has different firmware to the 5 kVA. I don't know why that is.

4 hours ago, Jay-Dee said:

In ICC it is reporting my CPU 1 is on version 51.50 and CPU 2 is on Version 1.10... I am presuming that is the unit vs the display firmware...

Yes, I believe so: 51.50 is the main DSP firmware, and 1.10 is the "display" firmware. The display firmware actually does a fair bit more than just drive the display, e.g. most of the PylonTech support (5 kVA models only) are in the display firmware.

Link to post
Share on other sites
6 hours ago, Jay-Dee said:

Any idea where I can get the 3kVA version?

Only from the supplier that sold you the inverter. Or from some web page / forum / etc where someone has posted a firmware update file that they obtained from their supplier. It doesn't have to be for your brand, but it has to be for your model. So for example if you have a Mecer SOL-I-AX-3K then you can use the firmware for an MPPSolar PIP-3024MK, for example (because they are the same machine with a different logo on the front). The "Zoo" post may help with identifying what is what.

Link to post
Share on other sites
  • 2 weeks later...
On 2020/01/18 at 1:55 PM, Calvin said:

OK, I have managed to fix it.

Essentially, the USB OTG firmware update still worked, exactly as described in the manual.

1. Copy dsp.hex to FAT32 formatted USB.

2. Connect with OTG cable to USB port.

3. Start USB menu by holding down top left button for 3 secs.

4. Select Upgrade firmware, confirm, when it says "UPG YES" it takes about 10 minutes.

All 3 now on 71.86😀

This exactly, saved my life. Also set with the same error after upgrading, and the display just showed fault code 32. I thought it was bricked, but it still responded after a few presses to go into the USB OTG upgrade mode.

Link to post
Share on other sites
  • 3 weeks later...

Tried to update the seem to be running into an error.

Downloaded Remote panel reflash 2.00 from  https://powerforum.co.za/files/file/49-king-remote-panel-reflash-200/

1. Formated a 1GB USB stick to Fat32

2. Extracted the MCU.hex file to the USB drive

3. USB menu by holding down top left button for 3 secs.

4. Selected UPG from the list

5 Get Error U03 (Document inside the USB disk with wrong format)

 

Current versions

U01 - 71.50

U02 - 01.21

U03 - 00.21

U04 - 00.00

 

any thoughts?

 

Link to post
Share on other sites
19 hours ago, Abnormal said:

2. Extracted the MCU.hex file to the USB drive

It looks like you can only update the main DSP firmware using the USB stick method. Crazy, since that means that the display processor can't update itself.

The display firmware contains strings such as "0:dsp.hex", "0:VM3.hex" and "0:AXPERT.TXT", but no string constant with the value "mcu.hex" (any case).

So I'd say you have to use a Windows PC, a USB to serial adapter, and the RS-232 port to update the display firmware.

Edited by Coulomb
Added "DSP"
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...