Jump to content

KODAK King Solar Off-Grid Inverter 5kW 48V Parallel Issues


Geoff Earnshaw
 Share

Recommended Posts

Hi all,

I have recently installed a handful of KODAK King Solar Off-Grid Inverter 5kW inverters and I am experiencing issues when running in Parallel.  

After two separate installations my findings were almost a carbon copy. After applying the setting detailed in the SOP documents the Master behaves quite unusually.

 

  • Program 2 – The AMPs keep changing – When I change the AMPS in accordance to the requirements the AMPS keeps changing on it's own. Master Only. Initially we set the maximum charging current to 50AMPS and immediately this changed. System defaulted to 120 and 140AMPS.

    (Max. charging current = utility charging current + solar charging current)

     

  • Program 11 – Maximum utility charging current - Was set to 20AMPS. Program 11 doesn’t appear to change it remains constant.

  •  Therefor according to the manual the Max. charging current should = utility charging current + solar charging current = 70AMPS.

    If setting value in program 02 is smaller than that in program in 11, which it was then inverter will apply charging value from program 02 for utility charger which should be 50AMPS.

    This is the case at both sites.

     

I ran a couple of tests today before installing finally setting the inverter to the PYL setting.

 

With the Inverters in Default mode there appears to be no issues on either inverters.

Master and Slave all appear to be functional and Inverters seem to be synchronised.

As soon as one applies the PYL and USE Settings the inverter values in Program 2 change.

 

I installed two other KODAK King 5kW Inverters as single units with Pylon's no issues. Just in Parallel operation. 

If anyone has anyone experienced anything similar or can give me some insights please let me know. 

 

I have been in touch with Segen but they are puzzled.

 

Please guys I am quite desperate. Any information may assist.

 

Regards,

 

Geoff 083 650 6699

 

 

Link to comment
Share on other sites

Do the paralleled inverters with this problem have identical main (U1) firmware versions? For example, both 71.86, as opposed to say one having 71.50.

I would expect setting 02 to change "on its own" only if setting 05 is PYL, and the inverters are successfully connected to Pylontech batteries.

Link to comment
Share on other sites

  • 4 months later...
21 hours ago, Plaashaas said:

Do they both have to be on the same firmware?

Short answer: yes.

Longer answer: it depends. If the firmwares are different enough, you'll just get a fault code 73 (error 73, firmware version inconsistent). But they get lazy with that testing, and sometimes when you don't get fault code 73, strange things still happen, like some machines switching to "new" (as opposed to master or slave), showing NE in the top row (middle two digits for older displays). It's possible that there are other, more subtle problems. So usually it's best to just flash them to the same firmware version if possible.

Link to comment
Share on other sites

Greetings and yes they do have identical firmware version on them.

I was in touch with the importer and distributor and they released a new firmware update.

Basically the new firmware disables the alarm from running with Error 69. Error 69 basically indicates that the Pylon batteries are full and the inverter should stop charging the batteries.

Bad coding.

 

Link to comment
Share on other sites

19 hours ago, Geoff Earnshaw said:

Error 69. Error 69 basically indicates that the Pylon batteries are full

Actually, it's a warning, not an error. It's just trying to be informative. Otherwise, you might wonder why the heck isn't this thing charging the battery.

Link to comment
Share on other sites

  • 1 month later...
On 2020/02/11 at 10:11 PM, Geoff Earnshaw said:

Hi all,

I have recently installed a handful of KODAK King Solar Off-Grid Inverter 5kW inverters and I am experiencing issues when running in Parallel.  

After two separate installations my findings were almost a carbon copy. After applying the setting detailed in the SOP documents the Master behaves quite unusually.

 

  • Program 2 – The AMPs keep changing – When I change the AMPS in accordance to the requirements the AMPS keeps changing on it's own. Master Only. Initially we set the maximum charging current to 50AMPS and immediately this changed. System defaulted to 120 and 140AMPS.

    (Max. charging current = utility charging current + solar charging current)

     

  • Program 11 – Maximum utility charging current - Was set to 20AMPS. Program 11 doesn’t appear to change it remains constant.

  •  Therefor according to the manual the Max. charging current should = utility charging current + solar charging current = 70AMPS.

    If setting value in program 02 is smaller than that in program in 11, which it was then inverter will apply charging value from program 02 for utility charger which should be 50AMPS.

    This is the case at both sites.

     

I ran a couple of tests today before installing finally setting the inverter to the PYL setting.

 

With the Inverters in Default mode there appears to be no issues on either inverters.

Master and Slave all appear to be functional and Inverters seem to be synchronised.

As soon as one applies the PYL and USE Settings the inverter values in Program 2 change.

 

I installed two other KODAK King 5kW Inverters as single units with Pylon's no issues. Just in Parallel operation. 

If anyone has anyone experienced anything similar or can give me some insights please let me know. 

 

I have been in touch with Segen but they are puzzled.

 

Please guys I am quite desperate. Any information may assist.

 

Regards,

 

Geoff 083 650 6699

 

 

 

On 2020/02/11 at 10:11 PM, Geoff Earnshaw said:

Hi all,

I have recently installed a handful of KODAK King Solar Off-Grid Inverter 5kW inverters and I am experiencing issues when running in Parallel.  

After two separate installations my findings were almost a carbon copy. After applying the setting detailed in the SOP documents the Master behaves quite unusually.

 

  • Program 2 – The AMPs keep changing – When I change the AMPS in accordance to the requirements the AMPS keeps changing on it's own. Master Only. Initially we set the maximum charging current to 50AMPS and immediately this changed. System defaulted to 120 and 140AMPS.

    (Max. charging current = utility charging current + solar charging current)

     

  • Program 11 – Maximum utility charging current - Was set to 20AMPS. Program 11 doesn’t appear to change it remains constant.

  •  Therefor according to the manual the Max. charging current should = utility charging current + solar charging current = 70AMPS.

    If setting value in program 02 is smaller than that in program in 11, which it was then inverter will apply charging value from program 02 for utility charger which should be 50AMPS.

    This is the case at both sites.

     

I ran a couple of tests today before installing finally setting the inverter to the PYL setting.

 

With the Inverters in Default mode there appears to be no issues on either inverters.

Master and Slave all appear to be functional and Inverters seem to be synchronised.

As soon as one applies the PYL and USE Settings the inverter values in Program 2 change.

 

I installed two other KODAK King 5kW Inverters as single units with Pylon's no issues. Just in Parallel operation. 

If anyone has anyone experienced anything similar or can give me some insights please let me know. 

 

I have been in touch with Segen but they are puzzled.

 

Please guys I am quite desperate. Any information may assist.

 

Regards,

 

Geoff 083 650 6699

 

 

Same setup and exactly the same problem. Firmware is the same.

Slave also keeps giving Err61 coms. error , but does not switch off and the same if master and slave switched.

Willie 0721232781

 

Link to comment
Share on other sites

I have 3 Kings in parallel with 8 Pylons, and they simply do not work with current firmware when using the PYL setting. 

I have ended up using the USE setting.  This works fine but you really need a management system (something like ICC) that can read the BMS and change the inverter settings based on the actual charge level.

Note that even when these bugs are sorted out there are 2 reasons why the ICC type of solution is better:

  1. Voltronics have so far not even tried to implement the most obvious functionality: allowing back to Grid and back to battery to be based on SOC rather than voltage.
  2. They charge the batteries to 53.2V, which is condierably too high.
Edited by Calvin
Link to comment
Share on other sites

17 hours ago, Calvin said:

I have 3 Kings in parallel with 8 Pylons, and they simply do not work with current firmware when using the PYL setting. 

I have ended up using the USE setting.  This works fine but you really need a management system (something like ICC) that can read the BMS and change the inverter settings based on the actual charge level.

Note that even when these bugs are sorted out there are 2 reasons why the ICC type of solution is better:

  1. Voltronics have so far not even tried to implement the most obvious functionality: allowing back to Grid and back to battery to be based on SOC rather than voltage.
  2. They charge the batteries to 53.2V, which is condierably too high.

Hi Calvin

Yes I do have the ICC software running.. but as a way to get information from inverters and batteries.

I will not let the software run the system, as it is to unreliable. "Yes Manie I hope you take note!!"

Software freezes to frequently and then SOC or whatever you use as reference is useless.

Did freeze again last night.. then makes the GPIO addition also not working.

Some say that the Pi running from a micro SD can be the problem , but have not tried to run PI4 from SSD.

So at the moment there is no foolproof  alternative.

Cheers 

Willie

 

Link to comment
Share on other sites

On 2020/08/31 at 11:32 AM, WNLHD2 said:

I will not let the software run the system, as it is to unreliable.

Hi Willie,

I do not use ICC myself - I have developed my own control system that run on an Arduino.  Micro-controllers like the Arduinos are far more reliable.

Having said that, I do use 3 Raspberry Pis in my home entertainment system and they have been in use since the early days of the first RaspPi - 2013 I think.  My experience with them is that 90% of all issues are related to the SD card - either bad connection or corruption.  I think that perhaps I have a problem once a year between the 3 of them.

Also, if you read the forums there appears to be many people who are very happy with ICC.  Have you tried running it on another PI/SD card?

Link to comment
Share on other sites

  • 1 month later...

Greeting all,

Please note that there is a full firmware update that has been released apparently addressing the KODAK King Solar Off-Grid Inverter 5kW Error 69 issues.

Named: Axpert KING Main CPU Reflash. I see that it is dated 29/12/2017. AxpertKING5KW71.93P (1) (2)

Available from Segen Solar. 

 

Link to comment
Share on other sites

  • 7 months later...

I made the mistake of buying 6x Kodak 5000W MKSII inverters for the family.

connected the first two in parallel => not even 5 min.   huge bang and smoke

Most mosfets and IGBT's gone to pieces. Maybe i made a mistake

connected the next 2 ,  without connecting net in and out  , just batteries and PV, com cables 

Same result, except i quickly switched off the batteries and PV .

I then connected the inverter that did not go BANG, but it created wild voltage swings and after 5 min it gave in the ghost.  

Don't recommend anyone buying these inverters - the software is not preventing overvoltage and or overcurrent to occur.

never mind all the code setups  - slave and master etc...      

When you call Segen technical , you get a store guy , who knows almost nothing. Well done guys.

Not sure what to do with the remaining 2.

Have an MPP PIP5048MK inverter running for about 3 years without a single problem.

Guess where i'm going next.

 

regards W

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...