Jump to content

Imeon 3.6 Upgrade problem with IMA-Box


jms49
 Share

Recommended Posts

I have an Imeon 3.6 inverter which I am upgrading to work with Pylontech US3000 lithium batteries. Imeon sent me the firmware/software updates for both the inverter and IMA-Box which I have just purchased. The firmware updates (DSP:17-04-26:17,30 and MCU:17-04-26,17:30) for the inverter and OS One update (v1.7.8.2) for the IMA-Box installed with no problems. I then connected the batteries (two in parallel with the link connection) to the IMA-Box using the CAN sockets. All Dip switches on the batteries are down (off). When I selected the PylontechUS3000 battery in the OS One software it was unable to connect and just keeps searching. Since the upgrade, the inverter will not charge the batteries either from the grid or PV panels but will discharge if there is no power input from the grid or PV panels. Also the inverter keeps randomly disconnecting from the grid when there is no power outage. I have checked all the connecting cables, reinstalled the software three times but still not working. Any suggestions please.

Link to comment
Share on other sites

  • 3 weeks later...

SORTED: The wiring configuration on the Pylontech CAN cable supplied was incorrect. A standard RJ45 cable will not work so check the pin configuration for the Pylontech battery and Imeon IMA-box.

  • (GND) Pin 2 (Battery) connects to Pin 8 (IMA-Box)
  • (CAN_H) Pin 4 (Battery) connects to Pin 1 (IMA-Box)
  • (CAN_L) Pin 5 (Battery) connects to Pin 2 (IMA-Box).

If necessary make your own cable it may be easier as only three connections are required.

Link to comment
Share on other sites

  • 4 months later...

Hi

i am in europe and having never ending problems with my Imeon 3.6 and IMA box. I have recieved Zero support from Imeon who do not reply to my emails or telephone calls. I tried to do an upgrade of my inverter however due to the network not being great it woudl appear as if it is corrupt. 

would you be able to send me a copy of the firmware you received? Can this be uploaded using USB instead of through the internet? Any help to get my system back and working would be appreciated. 

This is the info on my "about page"

IMEON 3.6
Número de serie del inversor:96131509100143
Número de serie de la Brain-board:CM170302B199
Firmware package:DSP/MCU: 3618070636A / 3615061788B, Protocol: V4.1.4
Versión linux:Linux 4.1.18e armv7l / Debian GNU Linux 8.6 (jessie)
Primer producción:2015-09-20 14:00:00
Dirección de la red LAN (con cable):192.168.1.109
Versión del paquete:1.7.8.3
Link to comment
Share on other sites

  • 8 months later...

Hi...

I live in Cape Town. Have had the Imeon inverter for around 5 years and have been really happy with it so far.   I am looking to upgrade to lithium batteries (looking at the Freedom Won brand).  Do you need the ima-box to properly run lithium. Does it also provide the Os.One web interface?  

Unfortunately imeon doesn't seem that well supported in SA anymore. Battle to find parts.   Where did you buy the Ima-Box from?

Link to comment
Share on other sites

  • 3 months later...

@WernerH,

 I also have an Imeon with IMA Box.  I currently have early version BlueNova batteries which do not support CAN with he Imeon.  I do believe you need the IMA Box as the CAN port is located on the IMA Box.  So the setup is you join the Imeon with the IMA Box and IMA Box connects with the batteries via CAN.  The IMA box then runs your OS.ONE also.

Regards, Rian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...