Jump to content

Growatt SPF 5000TL Inverter & UFO100ah LiFePO4 "PowerWall" Battery Issue (My Solution)


Recommended Posts

Hi Everyone, 

New here, and insanely tired so forgive my short robotic style post, but I just wanted to share this with anyone in case they end up having the same nightmare 20 hour troubleshooting session I just had.

Long story short, I had this system installed yesterday:




We didn't change any settings on the inverter or battery and I'm not using PV.

Nothing else but the battery DC was connected to the inverter on startup and initial charge.


After the install guys left the battery was still charging and everything worked great.

About 2-3 hours in, at about the time when the battery was fully charged the thing goes insane and I get this dreaded error:


Long story short I kept getting it even with zero load and just the battery and inverter isolated, and was almost about to contact Growatt or posting a thread here after reading the exhaustive thread on here about guys with the same inverters but using other batteries (like Pylons).


I also received the 08 error after a few mins running when changing the inverter #5 setting to "user" and dialing in the settings for 19, 20, 21 to the supposedly correct values from the battery tech spec on the UFO website.

That didn't work either. So that was already contrary to many other guys who used that mode to correct their own issues.

As reported in the other thread, setting #5 to L1 mode for Lithium just threw two errors (I think 03 and 20), but thanks to the other thread I knew if I managed to establish comms using a cable in that mode the error might go away, it was a long shot though since I had received zero comms cables with the battery and had no idea what type of cable I'd need. The battery manual was also useless, it didn't even list comms with an inverter as an option, purely a "PC" connection using one of the three RS485 ports.

So I began my quest of desperation, I grabbed two old UTP Cat5 fly-leads from my PC part stash. One was an old crossover and the other one was a straight through. I even tested them on a cable tester to make sure it's not one of those fly-leads I semi disposed off due to not working, thinking I might use it for something else one day. 

A few minutes later and a bunch of calculated brute-force attempts at switching cable types and ports I managed to boot up the inverter one last time with the "Li" icon finally showing up, no errors showing and it's been running for a few hours now with zero issues. This happened when using the BMS port on the inverter and the RS485 port next to the CAN bus on the battery, and the cable is a normal straight through Cat5.


Those who know more about this stuff will probably laugh at me, but I'm a Data Engineer and not an electrical guy so to me this stuff was all pretty damn new and I was ignorant enough to think I'd get away with not having to get my hands dirty, confident in the idea that buying a "kit" means it'll all just work once you hook it up. Thanks to this forum I knew at least how to go about trying everything I can on my side, so thank you to everyone I never spoke to but whose comments I spent the most of last night reading.

While this was going on I also received an email from someone at Solar Advice where I bought the kit from (emailed them earlier in the day and explained my issue).

This is the response I received, which is apparently another fix for it without using the BMS.

(I really wish someone would have at least relayed that info and not leave me to figure this out, it's supposed to be called a damn "kit" for a reason, it should just work with what you buy):


I won't be trying those settings for now unless for some reason something freaks out again.

I agree with @SiliconKid on this topic: Let the battery do the talking and measuring and leave the imprecise voltage-only comms out of it.

We'll see how this works out long term, but I hope I can at least save someone some headache on this topic.

I'll update if there's new issues or developments.

Edited by RaptorSA
Add photos
Link to comment
Share on other sites

  • 1 year later...

Good day, I have a strange problem that accured at one of my clients, 5kw Growatt inverter with a 100ah 4.8kwh UFO battery pack 48v, the system has been working fine, UPS system only through loadshedding,  we now had loadshedding and the battery drained completely,  strange, but now I can't get the battery to charge through the inverter?it shows setting 19 on the bottom right of the screen?I've tried adjusting the low DC settings and a few others and still nothing, the battery lcd screen lights up but no battery life on the battery indicator leds,  is there a way to charge the battery using the inverter?and also the inverter switches on using utility no problem,  any advice would be much appreciated,  thank u in advance,  Bryan. 

Link to comment
Share on other sites

  • 3 months later...


This is my first post in the forum. I’m getting a similar issue with my UFO 10kWh Lithium Batteries. (2 in parallel) and the MPP LVX6048 inverter. I’m pretty sure the BMS it’s getting troubles to communicate with the inverter. Someone with this configuration that could provide some light here?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...