Jump to content

Pylontech (Kodak) Force L1 RS232/485 comms


Anarchy2007
 Share

Recommended Posts

Hi there,

Does any one have any experience with the Kodak (pylontech) Force L1 lithium batteires' RS232 or RS485 comms? The RJ45 port (located on the bms) is labelled RS232 / RS485.
I used "Batteryview" and have tried RS232 2 wire (oddly no GND) as per the datasheet, tried GND on serial pin 5 from RJ45, tried GND from negative battery pole. Tried Cisco RS232 console cable pinouts the same goes for RS485 and RS485 to RS232 converter. But no connection  at all.

It comes with WiFi. I connected to the web portal of the battery system but it's basic WiFi setup and server addresses. At best I managed to connect it to my solis account but that's it as I assume the data lgger is actually a solis WiFi stick and will log Solis inverter data.

I'm starting to think that debug needs to enabled in some way to get comms.

This is my first time working with the Force L1 batteries and it seems like infomation regarding them is a little vague.
Can someone with knowledge of thes batteries maybe guide me in the right direction?
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...