Jump to content

Growatt inverter spf 5000ES with dyness 2.4kw battery setup


TJ Human
 Share

Recommended Posts

Hi. I have a Growatt SPF 5000 ES inverter connected to a dyness 2.4 kw battery with comms cable. Which plug do I use on the inverter for the comms cable? And on the inverter setting 5 when I put it on li ion setting,after that on which protocol setting do I put it for that specific battery? How will I know it is communicating with the battery?

Link to comment
Share on other sites

22 hours ago, TJ Human said:

Hi. I have a Growatt SPF 5000 ES inverter connected to a dyness 2.4 kw battery with comms cable. Which plug do I use on the inverter for the comms cable? And on the inverter setting 5 when I put it on li ion setting,after that on which protocol setting do I put it for that specific battery? How will I know it is communicating with the battery?

 

I'm pretty sure I read that you use the CAN bus and then use protocol 52

Edited by tetrasection
Link to comment
Share on other sites

I got 2 communicating cables with the battery,one which states gorwatt spf inberter and another one which can be used with other inverters but also says growatt(CAN).

Which one should i use?

Link to comment
Share on other sites

30 minutes ago, tetrasection said:

 

I'm pretty sure I read that you use the CAN bus and then use protocol 52

I got 2 communicating cables with the battery,one which states gorwatt spf inberter and another one which can be used with other inverters but also says growatt(CAN).

Which one should i use?

Link to comment
Share on other sites

On 2021/06/11 at 12:07 PM, TJ Human said:

Hi. I have a Growatt SPF 5000 ES inverter connected to a dyness 2.4 kw battery with comms cable. Which plug do I use on the inverter for the comms cable? And on the inverter setting 5 when I put it on li ion setting,after that on which protocol setting do I put it for that specific battery? How will I know it is communicating with the battery?

Hi TJ, Please have a look at this threat, there is few tips on how to get Dyness comms with Growatt. Also, note that you need to use RS485 for communication, not CAN

 

 

Link to comment
Share on other sites

4 hours ago, TJ Human said:

I got 2 communicating cables with the battery,one which states gorwatt spf inberter and another one which can be used with other inverters but also says growatt(CAN).

Which one should i use?

The es model can communicate with dyness batteries on the can port.

Link to comment
Share on other sites

I've pretty much got the same setup, growatt spf 5000es, dyness B4850 2.4kW battery. Guys from Setsolar did the installation, I can see its got the cable in the CAN port of the inverter. 

Link to comment
Share on other sites

20 hours ago, thoc said:

@TJ Human Did you come right with the settings on 05? Mine is set to "USE" and tweaked all the other options, it doesnt feel 100% yet so I'm thinking of trying the LI option instead...

Which firmware do you have on your growatt? You need the newer firmware for it to work properly in Li mode.

Link to comment
Share on other sites

I got it working on Li mode in setting number 5 and on protocol 01. Number 2 and 3 dipswitch set on on the battery and I got a cable with the battery for the SPF 5000 es battery and using port RS485 on inverter and seems to be working fine now.havent tested it with loadshedding yet so will see how it does. How do I check which firmware the inberter has on?

Link to comment
Share on other sites

2 minutes ago, TJ Human said:

I got it working on Li mode in setting number 5 and on protocol 01. Number 2 and 3 dipswitch set on on the battery and I got a cable with the battery for the SPF 5000 es battery and using port RS485 on inverter and seems to be working fine now.havent tested it with loadshedding yet so will see how it does. How do I check which firmware the inberter has on?

To check the firmware you press the "up" button twice when you're in the main screen. There are 2 numbers (top and bottom), one for the inverter and one for the charge controller.

Link to comment
Share on other sites

1 minute ago, tetrasection said:

To check the firmware you press the "up" button twice when you're in the main screen. There are 2 numbers (top and bottom), one for the inverter and one for the charge controller.

I will check later tonight and let you know which it is. Thanks

Link to comment
Share on other sites

Mine itself is 040-02-909 / 041-02-907 (bottom). But i'm using the CAN port instead though. I think I might still need to tweak the different settings a bit, I saw them in the thread hoohloc posted. What I find here is it runs on Solar during the day for about 3 hrs then suddenly the solar drops completely and it runs from Eskom instead, for about an hour then back to solar. So that's why I say its not all 100% yet and thinking I need to try Li setting instead....

Link to comment
Share on other sites

32 minutes ago, thoc said:

Mine itself is 040-02-909 / 041-02-907 (bottom). But i'm using the CAN port instead though. I think I might still need to tweak the different settings a bit, I saw them in the thread hoohloc posted. What I find here is it runs on Solar during the day for about 3 hrs then suddenly the solar drops completely and it runs from Eskom instead, for about an hour then back to solar. So that's why I say its not all 100% yet and thinking I need to try Li setting instead....

Yeah I was reading in the other thread that a firmware update fixed that issue. Your firmware is not the new one.

Edited by tetrasection
Link to comment
Share on other sites

1 hour ago, thoc said:

Mine itself is 040-02-909 / 041-02-907 (bottom). But i'm using the CAN port instead though. I think I might still need to tweak the different settings a bit, I saw them in the thread hoohloc posted. What I find here is it runs on Solar during the day for about 3 hrs then suddenly the solar drops completely and it runs from Eskom instead, for about an hour then back to solar. So that's why I say its not all 100% yet and thinking I need to try Li setting instead....

Mine is the same as this one. I would think it is the newer firmware,because the inverter is only 1 month old?

Link to comment
Share on other sites

1 minute ago, tetrasection said:

Not yet, I'm still waiting for the file from Growatt, should hopefully be able to do it soon.

@tetrasectionare you not getting it from that website you put up? Will you be able to send it to me aswell when you get the updates please?

Link to comment
Share on other sites

2 minutes ago, tetrasection said:

I left a message of the ShinePhone app, will gladly share once I've got it.

Thank you. I also send them a message on the app last week but no response in helping me. Everything seems to be working fine now but if the new firmware is better,why not.

Link to comment
Share on other sites

32 minutes ago, TJ Human said:

Thank you. I also send them a message on the app last week but no response in helping me. Everything seems to be working fine now but if the new firmware is better,why not.

Maybe I'm old school but I believe if everything is working well, don't fix it. Updating the Firmware might cause you to start having issues 😄

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...