Jump to content

WatchPower IOS app not loging in

Recommended Posts






I recently purchased a WatchPower wifi module for my mecer Axpert 5P64 inverter.

After connecting the device and configuring it to my home wireless internet (both of which are working correctly), I tried to register on the WatchPower IOS app.

It says registration successful, but when I try to log in again it says user name not found.

After trying to register again, it says that my device has already been registered.

I also tried the android app with the same message showing.


Is there any way I can be helped to get the app working? i'm sure I am using the correct user name and/or  alternatively is there a way to re-register the device.

Edited by ebrahim
Link to comment
Share on other sites

the info both from WatchPower, and Axpert says that is compatible, and the Wifi module does seem to be working with the three lights flashing (showing that the connection is correct and that it is sending info to the net), it seems to be the watchpower IOS account, its not allowing me to log in, totally shutting down my user account info (continuesly saying that the account is not found). were the device not compatible wouldn't it have allowed me to log onto the account and thereafter not show the device in the app itself.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...