Jump to content

Dyness Powerbox With Victron --> Settings Found


spark88
 Share

Recommended Posts

Hey all ...

I reached out to Dyness (China) for the settings required and battery cable configuration. I got a response the next day which was great.

----------

You need to make sure that the dip switch on the master battery is 0010. This is the default on battery from the factory.

Make sure to update you Venus firmware to at least 2.42

For the can bus use : CAN-bus BMS (500 kbit/s)

Make up a cable as per below:

185260600_ScreenShot2020-03-27at12_17_04AM.thumb.png.2485bc92af2e845f63955d772d968200.png

If all works well, then you should see "Dyness-L Battery" appear as a device on the Venus

On the Venus set the following:

Goto Settings -> System Setup -> Battery Monitor and choose "Dyness-L Battery on CAN-bus"

Goto Settings -> DVCC -> Turn on DVCC

Goto Settings -> DVCC -> Enable "Limit Charge Current"

Goto Settings -> DVCC -> Set maximum charge current = 100A

Goto Settings -> DVCC -> Turn OFF SVS

Goto Settings -> DVCC -> Turn ON STS

Goto Settings -> DVCC -> SCS should show as Disabled (External Control)

On the Inverter set the following:

  • Battery type = Lithium
  • Charge Curve = Fixed
  • Bulk Voltage: 53.5
  • Float Voltage: 51v
  • Sustain Voltage: 49v
  • Absorption Voltage: 52v
  • Absorption Time: 1hr
  • Cut off Voltage: 46v
  • DC Input low shutdown: 44v
  • DC Input low restart: 48v
  • DC Input low pre-alarm: 48v
  • Dynamic Cut Off Values: 46v (all options)
  • Restart off-set: 1.2v

Checking The Configuration

Goto Dyness-L Battery -> Parameters. If the battery is fully charged then CCL should show as 0.0A and DCL as 120A (30A per battery). This means that the battery is talking to the Inverter

Here is a list for other SOC's

476964191_ScreenShot2020-03-27at12_26_29AM.thumb.png.6ff2c8b8df34f04ed676d995440f2ea0.png

Hope this helps someone. Mine seems to be working well now.

Link to comment
Share on other sites

The "turn on STS" bit is interesting. The idea of shared temperature sense is that one temperature sensor is used for all the equipment so that they can compensate for temperature. But when the BMS dictates the charge voltage, temperature compensation isn't done anyway... so STS does nothing.

🙂

 

Link to comment
Share on other sites

2 hours ago, Armand said:

the CCGX only show 50ah capacity

That's what the BMS is sending in the CAN frame with ID 0x379. This is a fairly new extension to the CAN-bus protocol (November 2019), and it is a Victron initiative, ie we made it up, and the battery makers who want to integrate with us are expected to implement it (if they want to, it is optional, but really useful to have). Due to its newness, and the complete lack of support for the other items, I suspect they use 0x379 for something else and the 50 means something other than capacity.

This is screen is for information purposes only and so far only a few battery makers support it (BYD Premium, Pylontech 24V battery). The value is not used for anything else and the fact that it is wrong does not affect anything. Just ignore it.

Edited by plonkster
Link to comment
Share on other sites

  • 2 months later...

Hi Guys

 

I can't get a Dyness B4850 battery to connect with my Victron Multiplus 2 GX.

I have:

Updated all Victron Firmware.

Set the CAN-bus Profile - CAN-bus BMS (500 kbit/s) and used the Victron VE.Can to BMS CAN type B cable the right way around.

Set DVCC on.

 

Any ideas of where i'm going wrong?

 

Link to comment
Share on other sites

4 hours ago, Andrew P said:

Any ideas of where i'm going wrong?

What you can do is root the GX device, and then you can use an SSH client (PuTTy is commonly used on windows) to get a root shell on it. Then you can run candump to see the canbus communications. You'll probably type "candump can0", but here is an example from another type of GX device that has two CAN ports:

[email protected]:~# candump can1
  can1  1CEFFF24   [8]  66 99 20 01 18 03 00 00
  can1  1CEFFF24   [8]  66 99 D5 ED 47 08 00 00
  can1  1CEFFF24   [8]  66 99 8D ED 47 08 00 00
  can1       305   [8]  00 00 00 00 00 00 00 00
  can1       307   [8]  12 34 56 78 56 49 43 00

This one has a Victron VE.CanMPPT, which is why its sending these large 29-bit ids, but you should see something similar. If you see nothing (or if you only see the 0x305 and 0x307 frames), then there is no CAN-bus commications. 0x305 and 307 are keepalive messages sent by the GX device.

If you see CAN-bus comms, and it is still not working, ask me again... I may know... 🙂

 

Link to comment
Share on other sites

Problem solved.

The Dyness B4850 batteries I had didn't have dip switches, my supplier swopped them out for units with dip switches and now all is good.

 

New problem I just encountered with a multiplus 2 gx is the local wifi connection has vanished and not returned after rebooting the venus and restarting and whole system.

Anyone else had issues with Venus GX units?

Link to comment
Share on other sites

22 hours ago, Andrew P said:

Anyone else had issues with Venus GX units?

Yeah, it's one of those recurring issues with Wi-Fi. I found that unless you have nice strong WiFi, it tends to drop out and not always return. Best is to rig up some ethernet to it, or invest in a Wi-Fi repeater.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...