Jump to content

Ben Harper

Members
  • Content Count

    28
  • Joined

  • Last visited

  1. Thanks.. I guess what I'd really love to know is precisely how the "hybrid" circuit works. I clearly recall seeing in my telemetry a while ago that the load on the inverter was a sustained 4KW for many minutes (it's a 3KW model), and the inverter's overload protection clearly didn't kick in. I have no reason to believe that the overload circuitry is broken, because I often get the "beep beep" for a second or two as the washing machine element kicks in, but before my automated switchover has sent the washing machine back to grid power. So what I'm wondering is if the design of the hyb
  2. When in SUB mode it stays at 40 degrees 24/7 (unless temperature exceeds 40, in which case the fan switches on and bring it back down to 36, and the cycle repeats).
  3. I have something curious on my Axpert VMIII 3KW (2019): The temperature remains constant around 40 degrees when in SUB mode. When I switch to SBU mode (Solar is powering the loads by this time), then it drops off pretty close to ambient temperature. The load is under 500W here, for the duration of this graph. I'm curious if anybody can explain why this is the case.
  4. For posterity, in case anybody on the internet finds this "(NAK"... here is the C/C++ code for setting up the terminal as regular file device: https://github.com/bmharper/homepower/blob/master/server/inverter.cpp#L239 speed_t baud = B2400; // Speed settings (in this case, 2400 8N1) struct termios settings; int r = 0; if ((r = tcgetattr(FD, &settings)) != 0) { fprintf(stderr, "tcgetattr failed with %d\n", r); Close(); return false; } // baud rate r = cfsetospeed(&settings, baud); if ((r = cfsetospeed(&settings, baud)) != 0) { fprintf(stderr, "cfsetos
  5. Thanks @Coulomb, saved my bacon! I was missing a call to cfmakeraw() before calling tcsetattr(), so presumably the IO device was in "line" mode instead of "raw" mode. I can once again speak to my little inverter! Thanks for all the help!
  6. OK.. so I have the RJ45 -> RS232 -> USB cables plugged in, and I can clearly talk to the thing, but every command I issue responds with "(NAK". @Coulomb Have you ever seen this? All the code I can find on the internet doesn't seem to differentiate between talking over USB or RS-232. I know I've got the CRC correct, because it was working perfectly over USB. One other interesting thing.. after rebooting the inverter (ie all plugs out), the very first time I try to talk to it (asking it for QPIGS), it gives me "(PI30" response. Thereafter, it responds exclusively with "(NA
  7. Thanks @Coulomb.. that would explain why my adapter cable labelled RS485 doesn't work!! And thanks @JaseZA, I've ordered one of those adapters that you linked to... will see tomorrow.
  8. @JaseZA Thanks.. I have *something* resembling that plugged in now, and I can see a new serial device /dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller-if00-port0, but I'm unable to talk to it. Do you have any idea how I talk to the serial device instead of the USD HID?
  9. Thanks @JaseZA. What exactly do I need to buy in order to bridge between RS485 and USB?
  10. Update from thepowerstore.co.za -- apparently if you've opened the case (which I have done), then RCT won't honour the 2-year guarantee. So don't open the top case!
  11. I have a 3KW RCT VMIII, which I connect to a Raspberry Pi via USB cable to monitor it, using software that I wrote myself (https://github.com/bmharper/homepower). This software monitors the inverter's reported load, and uses that information to flip a set of contactors in my house, to either let heavy loads run from grid, or from the inverter. This way I can have more than 3KW devices potentially connected to the inverter, but the "heavy" ones go back to grid, if the inverter is unable to power them. The "essential" circuits always remain connected to the inverter. This setup has bee
  12. Thanks @Gerrie, I didn't think about the earth leakage! I can't imagine right now how the wiring will look for this, but I'll try figure it out.
  13. Thanks for the details @Gerrie. I happened to stop by ElectroMechanica in Cape Town yesterday, and an awesome guy there (Sheldon) sorted me out. I ended up getting two 25A 2p no 230V Hager contactors (http://www.em.co.za/Home/Modular-Relays-Contactors-Isolators/ERC225_2.html). I only need 4 poles in total, because I'm only switching my heavy loads. "Heavy" in my case is just washing machine and dish washer, so 25A should be enough. @BoxFish yes that's mostly correct, except I don't understand what you mean by "At night you want to change to grid and run off grid". Also, I really
×
×
  • Create New...