Jump to content

Home Assistant no longer getting data after Sunsynk firmware update - solved


RhysMcW

Recommended Posts

Hi all,
I had my Sunsynk 5kW firmware updated earlier today and have now noticed that I'm no longer receiving data into my Home Assistant via the RS485 connection.
I've restarted HA and also done a complete power off.
I've also tried changing the Baud rate in the Modbus setting in Node Red, my /dev/ttyUSB0 is still the same on my HA.
All was working fine until the update was done, which included the inverter resetting itself...
I'm just getting the following back in Node Red debug.

"Modbus Failure On State sending Get More About It By Logging"

old: M 3.1.6.2 / S  -- / C E.4.1.9
new: M 3.3.8.2 / S  -- / C E.4.2.6
I see the new MCU has "-0513" at the end

Anyone seen this or got any ideas please?

Edited by RhysMcW
updating subject to reflect solved
Link to comment
Share on other sites

I just tried moving the cable from the BMS485 port on the inverter to the RS485 port but no change...

have now also just done a full shut down on the inverter, complete power down, still not getting data into HA anymore

Edited by RhysMcW
adding additional note
Link to comment
Share on other sites

okay, so we're back to functional....
I found mention, in another forum post, of having to set the unit ID on the invert to "1" in the Advance settings, Multi-Inverter - there is a "Modbus SN" field.
strange that the setting was the same on the previous firmware version
images below - first is previous firmware version and second is new (current) version

319685821_2022-12-13advance-multiinverters400.jpg.68ccbc99a1ee9c64ae94bfac65f63180.jpg     2105843582_2022-12-23advance-multi-inverter400.jpg.16cdb3dd91c23052a73e3f7fbfa43c16.jpg

I changed the "Modbus SN" to show as "01" and now I'm getting data again.

BE WARNED though, changing that setting put the inverter in fault mode and it disconnected the power to the essential load and I had to do a complete power off and reset on to get it functioning again.

I'm just happy to be getting the data into HA again

Link to comment
Share on other sites

  • RhysMcW changed the title to Home Assistant no longer getting data after Sunsynk firmware update - solved

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...