Jump to content

Earth Leakage not working with 5KVA inverter


ZOL
 Share

Recommended Posts

Hi all the solar fundi's,

 

I discovered that the earth leakage connected to the feed from my Mecer SOL-I-AX-5M Inverter is not working correctly. Again the question arises: should the earth be kept separate from the neutral or not? If anybody can help with advice or a simple diagram, it will be highly appreciated.

Link to comment
Share on other sites

27 minutes ago, ZOL said:

Again the question arises: should the earth be kept separate from the neutral or not?

After the Earth Leakage definitely not be connected at all. The only bond between Neutral and Earth should be on the supply side of your Home/Property. After that the only bonding that should happen is during a grid failure when a secondary device/relay bonds the Inverter output Neutral to Earth. That bond should be broken before the inverter re-connects to grid again, otherwise any earth leakage on the inverter input will trip. 

Link to comment
Share on other sites

On ‎2020‎/‎04‎/‎09 at 10:10 PM, Jaco de Jongh said:

After that the only bonding that should happen is during a grid failure when a secondary device/relay bonds the Inverter output Neutral to Earth. That bond should be broken before the inverter re-connects to grid again, otherwise any earth leakage on the inverter input will trip. 

Jaco,

Do you have a diagram how to connect such a relay perhaps?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...