Jump to content

Mever 1200Va Trolley in error mode


Basil Katakuzinos

Recommended Posts

Good day

I have a Mecer 1200Va 700watt inverter trolley with a 100Ah Revov 1st life lithium battery. Bought from Geewiz
I have cycled the battery no more than 5 times and never below 70% SOC (IE only 30% Depth of discharge)

Voltage is at 13.7 Volts confirmed with a multimeter and the BMS app.

Inverter charges the battery and is fine until the power is disconnected.

When the power disconnects I can hear the relay thud and then immediately after the inverter displays the error screen and an audible beep is heard.

I have disconnected all loads from the inverter, the same thing occurs. I have never drawn more than 400Watts from the inverter and my average load is about 150Watts.

 

 

This all stated today after i left home for a week. When I left I switched the inverter off and unplugged it, battery was fully charged when I left and fully charged when I arrived a week later (today).

Plugged everything back in and this is when the errors as stated above started, inverter is about a month old.

 

 

Edit:

This is at a different location to the below mentioned Victron system, which to this day has worked without a single issue.

Charging at 10A

Edited by Basil Katakuzinos
Link to comment
Share on other sites

9 hours ago, Basil Katakuzinos said:

Good day

I have a Mecer 1200Va 700watt inverter trolley with a 100Ah Revov 1st life lithium battery. Bought from Geewiz
I have cycled the battery no more than 5 times and never below 70% SOC (IE only 30% Depth of discharge)

Voltage is at 13.7 Volts confirmed with a multimeter and the BMS app.

Inverter charges the battery and is fine until the power is disconnected.

When the power disconnects I can hear the relay thud and then immediately after the inverter displays the error screen and an audible beep is heard.

I have disconnected all loads from the inverter, the same thing occurs. I have never drawn more than 400Watts from the inverter and my average load is about 150Watts.

 

 

This all stated today after i left home for a week. When I left I switched the inverter off and unplugged it, battery was fully charged when I left and fully charged when I arrived a week later (today).

Plugged everything back in and this is when the errors as stated above started, inverter is about a month old.

 

 

Edit:

This is at a different location to the below mentioned Victron system, which to this day has worked without a single issue.

Charging at 10A

Hi @Basil Katakuzinos can you perhaps perform a similiar test with a car battery,  so we can learn wether its battery or inverter related.

 

 

Link to comment
Share on other sites

Hi @Basil Katakuzinos,

If I am not mistaken those Mecer 1200VA Trolley inverters use the Mecer IVR-1200 desktop inverters such as the inverter in the product sheet attached.IVR-1200LBKS and IVR-2400LBKS.pdf

If this is the case please note that these units are not compatible with lithium batteries as per the supplier Mustek where Geewiz would have purchased the inverter from.
Was this unit sold as a bundle created by Geewiz or did you individually purchase the Inverter trolley and lithium battery as separate items in your cart?

If you follow the suggestion from @BritishRacingGreen by using a car battery you would most likely see a very different result.

Link to comment
Share on other sites

4 hours ago, LLawrence said:

Hi @Basil Katakuzinos,

If I am not mistaken those Mecer 1200VA Trolley inverters use the Mecer IVR-1200 desktop inverters such as the inverter in the product sheet attached.IVR-1200LBKS and IVR-2400LBKS.pdf

If this is the case please note that these units are not compatible with lithium batteries as per the supplier Mustek where Geewiz would have purchased the inverter from.
Was this unit sold as a bundle created by Geewiz or did you individually purchase the Inverter trolley and lithium battery as separate items in your cart?

If you follow the suggestion from @BritishRacingGreen by using a car battery you would most likely see a very different result.

Was purchased as a bundle, could you please indicate where Mecer states this incompatibility so I have a leg to stand on when I complain to Geewiz. 

https://www.geewiz.co.za/long-run-ups-inverter-battery/178181-1200va-mecer-inverter-100ah-lithium-battery-6-hour-battery-life-kit-720w-with-lithium-battery-3000-cycles.html

Link to comment
Share on other sites

11 hours ago, BritishRacingGreen said:

Hi @Basil Katakuzinos can you perhaps perform a similiar test with a car battery,  so we can learn wether its battery or inverter related.

 

 

A very good point. 

Now there are cases where 2 friends bought the same inverter. One using a S-100 and one a Revov. After a week the guy with Revov found his inverter will not switch on. Some tests were done and both inverters were fine coupled to the S-100 or a lead acid battery. 

Surely the manufacturers can sort this out as it was sold as a compatible bundle. 

Link to comment
Share on other sites

10 minutes ago, Scorp007 said:

A very good point. 

Now there are cases where 2 friends bought the same inverter. One using a S-100 and one a Revov. After a week the guy with Revov found his inverter will not switch on. Some tests were done and both inverters were fine coupled to the S-100 or a lead acid battery. 

Surely the manufacturers can sort this out as it was sold as a compatible bundle. 

Gewizz is closed for the week as they are moving and I woukd have to ship it from Stellenbosch to Joburg. 

Was planning on taking it to Mustek in cape Town tomorrow but after hearing this I am going to test in on a car battery tomorrow ( for the benifit of knowledge on the forum) and then email gewizz and tell them I will be returning the kit next week with the expectation of reviving a compatable inverter or a full refund(belive this is realistic and within the bounds of the CPA? ) . 

 

Now question is who will be liable for the courier cost and how the hell do I safely wrap the entire kit so it gets there in one piece, I didn't keep the shipping pallet.

Link to comment
Share on other sites

Hi @Basil Katakuzinos,

Sorry for the late reply.
This was initially advised to me by our Mustek account manager that those units are to be used with Lead Acid and gel batteries only, the model up which is a wall mounted 1200VA\1000W unit is however lithium compatible.

I have just popped him an email verifying and he has confirmed this is 100% correct. Only their MPPT units are, see attached product sheet.
Communica based in Pardon Eiland seem to have stock according to their website: https://www.communica.co.za/products/ivr-1200mppt

Unfortunately due to privacy and POPI reasons I am unable to share my email trail between my Mustek AM and I where he states that the unit you currently have is not Lithium compatible. 

Mecer IVR1200 & 2400MPPT.pdf

Edited by LLawrence
Link to comment
Share on other sites

@Basil Katakuzinos If it is worth anything, Communica does at least state that the IVR1200LBKS units are not compatible with Lithium batteries
https://www.communica.co.za/products/ivr-1200lbks?variant=31833145933897

However you can reach out to Mustek via their Mecer enquiries page asking for confirmation whether the units are lithium compatible: https://mustek.co.za/mecer-edge/
I would also suggest that your state that the unit was purchased as a bundle through Geewiz in the event that Mustek refuses to fix the unit under warranty in the future due to using with incompatible battery chemistry. 
When filling out the enquiry form select the Mecer under the All Brands drop down box

Doing the above should also help by getting the Mecer product manager or Mustek AM for Geewiz to inform the guys in Geewiz that this bundle is not compatible. Saving future buyer the same frustration you are currently experiencing 

Link to comment
Share on other sites

On 2023/04/18 at 9:02 AM, Basil Katakuzinos said:

Caught my inverter charging the battery at 10A while the fan is off, that can not be a good sign...

That should not be too much of a warning, the unit should switch the fans once it reaches a certain internal temperature which on that unit should be around 40 degrees. Considering that it is charging at 10A apposed to the 25A option could be the reason that is is not reaching the 40 degree mark, that plus the ambient temperature is most likely colder as we entered Autumn.
 

On 2023/04/17 at 3:49 PM, Basil Katakuzinos said:

Thanks @LLawrence.

Inverter did not work off of their batteries at their factory either. Inverter main board has been replaced and it works fine now. Am busy arguing with Geewiz now about these inverters not being compatible with lithium.

 

Would still suggest getting in touch with Mustek as per my previous post so that you have a leg to stand on with your fight between Geewiz

 

Link to comment
Share on other sites

On 2023/04/18 at 9:02 AM, Basil Katakuzinos said:

Caught my inverter charging the battery at 10A while the fan is off, that can not be a good sign...

That is correct and normal operation. That Mecer inverter uses the voltage to determine whether to turn on the fan during charging, not the current draw. So, the voltage is high enough for the fan to not turn on, but the lithium battery is still being charged as you have noted. You have correct set the max charge current to 10A. If you had set it to 20A then the higher charge current without fan would have led to it blowing up. I have taped mine up with tape to ensure that nobody inadvertently selects 20A charge current. On other forums they suggest adding in a 12V PC fan to cool the unit when the built in fan does not run.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...