Jump to content

Remote Panel Axpert 5kW VMIII (Probably Bricked)


Recommended Posts

Hello all,

I few days a go, I decided to update my Axpert 5Kw VM III firmware, but unexpectectly I got an error in the middle of the remote panel reflash process. (PC via RS232 communication cable)

Now my panel is not responding, meaning that nothing appears in my LCD and none of the buttons, including power switch are working.

Due to current issue my inverter will not even boot-up, since probably the remote panel is not sending any commands to internal inverter board to initiate power up sequence.

Is there any way to restore/reflash the remote panel thought any other method?

Thanks in advance.

Link to comment
Share on other sites

13 hours ago, jarjarbeens said:

unexpectectly I got an error in the middle of the remote panel reflash process. (PC via RS232 communication cable)

Now my panel is not responding

Don't panic. I assume it was the main DSP firmware that you were updating; I don't know what happens to the display when the DSP is just running the bootstrap loader.

In any case, follow the steps in this post: If you think your inverter is bricked.

Link to comment
Share on other sites

Hello @Coulomb,

Thank you for your more than welcome feedback. I've tried all combinations with no success. It is like the remote control display is totally dead and no answer/communication with it is possible.

Tried flashing both remote panel and main firmware using SW found here: 


Really I can't believe that there is no such other way to restore it to factory default SW.

Link to comment
Share on other sites

7 hours ago, jarjarbeens said:

Really I can't believe that there is no such other way to restore it to factory default SW.

There isn't room for a spare copy of the firmware. By the nature of flash memory, before you start writing the new firmware, you have to erase the old firmware.

Link to comment
Share on other sites

Thank you @Coulomb, @Jacques69 and @Calvin for your comments/feedback.

The biggest difference which I'm seeing, from what people have experiences and posted is that when they are trying to flash again LCD there is a sort existing communication happening between remote panel and PC. Sometimes this seem might fail but by retrying finally correct flashing is achieved.

In my case this is not happening. I can clearly see that COM port is openned (selected approapiate COM numebr in Remote Panel_ReflashTool), but after some seconds, more or less 1 min, I get error message that there is no answer from UPS.

No other methoud available.

Just in case, I ordered new RS232 - USB converter to discart any cable communication issue.

Link to comment
Share on other sites

Hello all,

Good news. Finally succeded to re-flash  my remote panel and make it work again!!!

These are the steps that I followed.

1 - Connect all (PC to Inverter via RS232 to USB cable) with no power supply given to the Inverter (No battery and No AC IN).

2 - Have RemotePanel_Reflash_MCU SW prepared on PC. (Correct COM port selected)

3 - Provide power supply to inverter (AC In) and immediately (only few seconds after) click on "Update MCU" button in RemotePanel_Reflash_MCU SW.

After steps 3 I started seeing that flash started. More or less after 10 minutes the flash was completed and LCD remote panel was working again.

Thank you guys for the support given. Probably this thread will be useable for someone that will experience same issue in the future.


Link to comment
Share on other sites

  • 5 months later...
9 hours ago, misiekgab said:

if someone has any idea about the black display

I assume that when the inverter powers up (fans to full speed briefly), you don't get any LEDs come on the remote display, or backlight from the display, after a delay of 1-2 seconds?

Next thing might be an RJ-45 breakout box or similar, to check for power from the inverter. With respect to pin 1 ("GND"), you should see +12 V at pin 2, and -12 V at pin 3. Pin 6 should have a negative voltage, I measured -14 V on mine, being the RS-232 data from the inverter. Pin 5 is data from the removable display to the inverter, which read as just slightly positive for me with the removable display not connected.

If all the above are good, it seems you should see some activity on the display if it's not faulty.

There are SMD fuses on the display's PCB on the +12 and -12 V signals (pins 2 and 3 respectively). It would be worth checking them for conductivity, and if open circuit, check for a short or low resistance on the other side of the fuse(s).

The LC display connects to the main PCB via 6 pins (CN6 on the main PCB). Check for bent pins and alignment.

The removable display comes apart easily with 4 Philips screws. Fuse locations are below; F3 is for +12 V, which likely powers most of the board via the 7805 regulator on the other side of the board.


Edited by Coulomb
Link to comment
Share on other sites

On 2.07.2021 at 05:51, Coulomb said:

Zakładam, że po włączeniu falownika (wentylatory na krótko na pełne obroty) nie pojawiają się żadne diody na zdalnym wyświetlaczu, ani podświetlenie wyświetlacza, po opóźnieniu 1-2 sekund?

Następną rzeczą może być skrzynka zaciskowa RJ-45 lub podobna, aby sprawdzić zasilanie z falownika. Jeśli chodzi o pin 1 ("GND"), powinieneś zobaczyć +12 V na pinie 2 i -12 V na pinie 3. Pin 6 powinien mieć napięcie ujemne, zmierzyłem -14 V na moim, będącym RS-232 dane z falownika. Pin 5 to dane z wymiennego wyświetlacza do falownika, co dla mnie odczytało się jako lekko pozytywne przy niepodłączonym wymiennym wyświetlaczu.

Jeśli wszystkie powyższe są dobre, wygląda na to, że powinieneś zobaczyć jakąś aktywność na wyświetlaczu, jeśli nie jest uszkodzony.

Na płytce wyświetlacza znajdują się bezpieczniki SMD na sygnałach +12 i -12 V (odpowiednio piny 2 i 3). Warto sprawdzić je pod kątem przewodności, a jeśli obwód jest otwarty, sprawdź, czy nie ma zwarcia lub niskiej rezystancji po drugiej stronie bezpiecznika(ów).

Wyświetlacz LC łączy się z główną płytką drukowaną za pomocą 6 pinów (CN6 na głównej płytce drukowanej). Sprawdź wygięte sworznie i wyrównanie.

Zdejmowany wyświetlacz można łatwo rozłożyć za pomocą 4 śrub Philips. Lokalizacje bezpieczników są poniżej; F3 oznacza napięcie +12 V, które prawdopodobnie zasila większość płyty poprzez regulator 7805 po drugiej stronie płyty.

298666357_Wyjmowane bezpieczniki PCB.jpg.27b51ab71a23c09f859fd2b74c905334.jpg

The fuses are checked, the voltages are there, I replaced the 817 optocouplers and 100uf capacitors to be sure, I have a suspicion of the processor because there is also no communication between pc and bluetooth.

Link to comment
Share on other sites

On 2021/07/03 at 7:23 PM, misiekgab said:

I have a suspicion of the processor...

Dang. Sounds like you'll need a new removable display, or have it replaced under warranty if possible. If your inverter supplier can't sell you one, you might be able to get one from Ebay/Ali Express/etc.

Link to comment
Share on other sites

  • 8 months later...

Hey guys


Thanks a million! I had the same experience with my 48V VMIII tonight. Updated main FW to 41.17 as per link in another thread on this forum, but display was not working after the update. Tried what jarjarbeens  said  with no success initially. I Just kept trying and trying and FINALLY got communication between the flashing tool and the inverter after about 20 attempts, trying different sequences.  When I powered the inverter on after the Main FW update, you could hear relays clicking with the fans on. The fans would go off after a few seconds, with some relay clicking that followed.

I followed what Jajarbeens posted above. The only thing I can add is that the power button needs to be IN (on) on the removable display. I got success when I pressed "Update MCU" on the flash tool about 3-4 seconds after I switched the AC power to the inverter on, just before the fans stopped. I figure that would before the normal starting 6 second countdown elapsed. Took about 20 seconds and then the flash started. Whole flash took 9 minutes and the display came on immediately after the flash completed. Restarted the inverter and confirmed that the Main FW was indeed 41.17, and the MCU version is 02.66 (that coulomb provided).

Once again thank you for all the generous information on this forum.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...