Jump to content

Growatt Firmware Updates


Tsa
 Share

Recommended Posts

Anyone ever have their FW update only display "Send Start!" continuously when doing FW upgrade on a Growatt inverter via ISP tool?

Getting this on multiple computers with a mix of Win7 and Win10. Inverter registers on COM port as soon as you plug it in.

SendStart.thumb.JPG.bab3f2f927039d35c9788ee4acd7de56.JPG

Edited by Tsa
Link to comment
Share on other sites

  • 5 months later...

Hi

Mine went into that state due to a bricked COM board after applying a FW update supplied by Mahone. They sent me a new COM board, but the inverter was eventually replaced by the supplier after weeks of troubleshooting with Mahone and getting nowhere. 

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hi all. I had this exact same problem with the comms board upgrade on my spf 5000 tl. It was stuck at Send Start. Eventually I got it to flash by following these steps:

  • Switch off all source (PV and AC) input and remove all load. Inverter must only be connected to batteries
  • Reset the inverter using the button procedure as described in the fw update procedure docs (pressing 2nd and 3rd button together and entering the password)
  • Exit the reset menu and power down the inverter. Power down the batteries as well.
  • Disconnect the batteries and remove bms cable if present as well as the wifi dongle.
  • Connect the USB cable to your PC and connect the batteries again.
  • Power up the batteries and the inverter.
  • Flash the firmware file now - mine worked at this stage (finally!)
  • Power down everything again, connect bms, wifi dongle, etc. and power up again.
  • I guess you can reset to factory settings again with the button procedure as recommended by the flash instructions if need be.
  • Configure all settings - now it should work as intended.

After the comms board update my wifi dongle works again on the 500.9 firmware with BMS active (Li setting 02)

Edited by Johan-Henry
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Hello All,

I am having the exact same problem with my SPS5000TL. The fist update worked. When I did the 2nd one, the same SEND: START keeps going and going. Nothing gets sent to the inverter. Even after an entire day of resetting the router by disconnecting the battery, reconnecting than starting the inverter. The screen wont even come on now. The lights on the communication board work though. Does anyone know if there is a hard reset or restore to factory setting procedure?  

@Johan-Henry can you please send me that FW procedure document? The on I have make no mention of the restarting with buttons procedure.  

Link to comment
Share on other sites

Hi @Neil27 I found the reset instructions with the firmware from a post by Fatboy here: 

 

 

There is a video on how to do it as well as a tips.txt file:

1£¬connect battery well£¬disconnect grid utility£¬
2£¬press the second and the third bottom at the same time£¬
3£¬password 305
4£¬up or down to page 34
5£¬press enter bottom to get into rst setting
6£¬press enter bottom to reset£¬wait for a while£¬it will finish resetting

 

Basically it resets the device to factory defaults. I found this step is essential when upgrading firmware, before upgrading and after.

 

The screen going blank after a fw update also happened to me, luckily there is a recovery procedure at the end of one of the update instruction files:

NOTE:
Sometimes updating may fail, you may close the inverter by disconnect battery break and close

ISP tool and disconnect USB line. Confirm the inverter is not power by battery or PV or utility. Then you connect USB line again, and open ISP tool do the same step as above, after you press

Flash button, you let the inverter power on. Wait for several minutes the update will go on.

 

Edited by Johan-Henry
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...