Jump to content

3kW Infini VS Pre-paid


Wetkit
 Share

Recommended Posts

Right,

So my Infini has propably been running now for close to 2 years. To date have not had any major problems, so well worth the money.

Recently I have upgraded my battery bank from 8 x Trojan T105 to x 16 :)

So now I am running from solar and battery power during the day and from Eksdom during the night.

Thing is, I still have extra PV power available during the day, so would like to utilise that as well.

 

So I ordered a Modbus comms card and energy meter.

The idea is to have ZERO consumption during daylight hours, even if the load is NOT connected to the Infini, so similar to the Goodwee.

It all started well, but very soon the cracks appeared. It seems like as soon as a large load would switch off, the Infini does not re-act fast enough and thus starts to push power back onto the grid.

This does not please my Conlog pre-paid meter and it switches off mains power.

So with a looooong story to the muni, I finally get them to replace the pre-paid meter with a diffrent unit. Unfortunately this is also a Conlog unit and also disconnects when seeing reverse feed :(

 

The old Conlog meter was a BEC23 and the new one is a BEC44 with remote. Both has reverse blocking.

 

So for now I am back to running standard mode.

If anybody had a similar problem, please share.

Link to comment
Share on other sites

I have a Conlog BEC23 that so far hasn't tripped. Different inverter, but same generic setup with a modbus meter and a small linux computer running the control software. Here it is (with the rs485 cable still hanging out of the DB at that point...)

db_1.jpg

Link to comment
Share on other sites

  • 2 months later...

Right, so finally I think I have cracked the case on this one.

My Infini was always set-up as "Grid-Tie with Backup (II)". In this mode the LOAD gets priority and the battery 2nd. No matter what I tried with settings in this mode, there would always bee too much power exported and the pre-paid meter would trip.

So during the past couple of days I have tried nearly every setting and configuration available. In the end I think I have a mode and settings that is working :D

Currently I have it on "Grid-Tie with Backup (I)". So far it is running fine and power export is working well. I have added my settings below if there is someone thats got the same issue or wanting expand their system.

 

Infini Mode Settings.png

Infini Power Settings.png

Link to comment
Share on other sites

I think it is wholly dependent on how fast the inverter tracks, but also how hard it tries to hit zero. The Conlog meters uses a 15-second window within which the average reverse power must remain below 40 watts. One way to avoid the tripping is simply to overcompensate: When you find yourself pushing back into the grid, pull back so sharply that you end up consuming from the grid before drifting back to zero. This is what I see me ESS system doing, when it pulls back it tends to overdo it. That might be its saving grace.

Simple math: 600W for one second is equivalent to 40W over 15 seconds, but 1200W for one second followed by 900W in the other direction for another second also evens out at 600Ws (watt-seconds). Of course you need somewhere to put 900W for a second... like a battery for example. Anyway, I don't think the Victron system was actually designed to do this, I think I got lucky: It probably uses a similar averaging setup to the meter, and because it always overcompensates I end up with a nice low average.

Link to comment
Share on other sites

With your settings on the pictures it does not look like you are exporting.

Why not just lower the export value?

Sent from my SM-G920F using Tapatalk

Link to comment
Share on other sites

In other modes the Load is priority, then battery and then grid. Perhaps the internal control loops were never tested like I had it setup???

 

Manie, if you enable the feed to grid, ALL available power would be exported to grid, causing the pre-paid meter to trip immediately.

With the smart power meter and the set-up now, the Infini tries to manage the power coming into my home at Zero.

So, even if my oven is not connected to the invertor, if I start the oven now, excess PV will be "pushed back" onto the grid up to where my consumption reads Zero :)

The ideal for me now is to have ZERO Eskom consumption, similar to "off grid" but without the penalty of being registered and billed as a SSEG.

Link to comment
Share on other sites

26 minutes ago, Wetkit said:

Manie, if you enable the feed to grid, ALL available power would be exported to grid, causing the pre-paid meter to trip immediately.

The way I've always understood it is if the "Allow to feed-in to grid" option is enabled, the inverter will feed power to the grid up to the value set in "Max feed-in grid power", so in your case nothing will feed in, but if you enable "Allow to feed-in to grid" the inverter will feed up to 1000W in to the grid.

Link to comment
Share on other sites

As super said. This is how i operate my infini. However i use my own app to ajust the settings to run on SOC and time controll after hours.

Sent from my SM-G920F using Tapatalk


Link to comment
Share on other sites

Keep in mind that this inverter runs in grid-interactive mode and therefore all loads (whether on the input or output side) is actually powered by the grid while the inverter behaves like a GTI (except during an outage). The decision the inverter has to make is how much energy to push back.

When you use the internal current sensor and disable feedback, the inverter "feeds back" just enough power to power the devices on the output, aiming for zero on the input. When you use an external modbus meter (and disable feedback), THAT meter replaces the internal current sense and now it will attempt to feed back enough power to zero the external meter. Any appliance living on the input side of the inverter, but downstream from the modbus meter, can then benefit from surplus energy. This would include the geyser and stove and all those heavy appliances you normally leave on the grid.

In other words, with Wetkit's setup, the inverter counter-intuitively feeds energy back from its input to the rest of the house, but it still attempts to avoid feeding it to the grid because you told it to.

Of course the additional delay of communicating with the modbus meter also comes into play.

Link to comment
Share on other sites

14 hours ago, plonkster said:

When you use an external modbus meter (and disable feedback), THAT meter replaces the internal current sense and now it will attempt to feed back enough power to zero the external meter.

Any appliance living on the input side of the inverter, but downstream from the modbus meter, can then benefit from surplus energy. This would include the geyser and stove and all those heavy appliances you normally leave on the grid.

You said it best, thanks!!!

Link to comment
Share on other sites

43 minutes ago, Wetkit said:

You said it best, thanks!!!

Hey, this stuff gets even more confusing when you combine equipment. In the CCGX there is not only a similar option, there is TWO! There is one specifically for limiting the Fronius GTI (if you have one), and then there is a second one that works the same as the Infini, if you turn it off, it still feeds back, just not past the modbus meter :-)

Selection_011.png

Selection_012.png

Link to comment
Share on other sites

I have tried feeding back to the grid just to see what would happen but only for a few hours :)

My post paid meter is aware of the reversal of the current flow but it still bills me, apparently its a built in  fail safe to prevent people swapping the input and output feeds and running the meter in reverse.

Just a quick question, if I set my infinisolar to Grid tie with backup (II) then the load is supplied first and battery charged second. I was happy with this as the battery was fully charged around mid day everyday but I suspect that it isnt a full charge as the infini is only aware of the voltage of the bank and tries to decide based on that what the SOC is. Should I be concerned about it? The BMV says its at 100% SOC?

The reason for my concern is I set the inverter to Grid tie with backup (I) the other day and they battery bank was still charging at 4PM even though the BMV said it was 100% at around mid day. Obviously the bank had priority.

What is the consensus? Which setting would you recommend?

 

Link to comment
Share on other sites

@Wetkit , I have seen that in mode 2, the inverter is pushing around 20W constantly to the battery bank once it is fully charged. I have no issue with that. What worries me is that in mode 1, the inverter was still pushing 3 - 400W at 4PM to the battery. I would have assumed that the battery would have been fully charged sooner in mode 1 as it has priority?

Which mode are you currently using?

Link to comment
Share on other sites

  • 2 weeks later...

So looks like all my excitement was for nothing :(

Looking at my stats now and the power consumption, it does not look like this is working.

The only mode where it does look to be trying to keep power consumption at Zero, is "Grid Tie with Backup (II)", but then the inv does not re-act fast enough and the meter trips...

 

Link to comment
Share on other sites

I'm beginning to think that the inverter might in fact use a PID-controller to approach zero. With ESS it seems the D-bit and perhaps even the I-bit is small or not there (so it follows the red line). It tends to oscillate a bit and probably comes up with a lower average because of that.img1238.gif.f989c33845cac84cdcd280af52688dc0.gif

Link to comment
Share on other sites

  • 4 months later...

Wetkit...

 

I also have an infini 3kw plus. I have the SDM630 modbus meter. My smart meter doesnt trip, however my infini is not limiting exported power and is exporting all excess power to the grid.

 

Did you manage to get yours to limit export to zero?

 

Link to comment
Share on other sites

good news. My infini 3Kw plus with SDM630 meter is working well and limiting power to the grid as it should be!

The magic in my case was unchecking (taking away the tick) on the 'export to grid' setting in grid tie with backup II mode and also running a new piece of signal cable away from any power cables between the inverter and the meter situated 30 metres from inverter. All my other settings are as per infini , Modbus card and SDM630 documentation.

When I used a piece of signal cable that was running in same conduit as my power cables the infini wasnt getting any comms from the SDM 630 and was only paying attention to its internal current shunt.

I find that if I unplug the RS485 link I get the same effect/fault as using a signal cable that is running in same conduit as power cable.

If I tick the box for 'export to grid' then the infini runs full throttle into the grid with no limitation.

I note that the feed in to grid calibration does in fact work and one can fine tune the 'sweet spot' so that there is virtually no over and undershoot (within approx 100watts) related to feeding back into the grid.

I note the limiter takes between 5 and 15 seconds to react to changing load conditions.

Having driven myself bonkers trying everything else..... I had a hunch the 220V wiring was overowering the piddly litle RS485 signals due to the cose proximity and long paralell run next to power cables. Nex I am going ot order a RS485 wireless link from fleabay and get rid of the wires altogether.

My Infini is working well, but has a vague burning smell - do these units suffer from problems with failing capacitors?

hope my info helps others.

Regards

Ralph

Link to comment
Share on other sites

9 hours ago, ralph said:

I note the limiter takes between 5 and 15 seconds to react to changing load conditions.

Wow. I was told the Multiplus is slow, but the Multi is much faster than this. It starts reacting within a second, but it takes 3 to 5 before it stabilises on the new power level. It does overshoot a bit (pull back too fast) which is good for prepaid meters.

I think Wetkit already tried backup mode II. Could you tell us what make prepaid meter you have?

Link to comment
Share on other sites

I opened up the top cover on my infini today to track down the burning smell. It seems to come from the upper left choke. I put a computer fan on top of the unit running permanently and this appears to have cooled the choke off and the smell has gone away. I wonder why that choke is heating up.

Link to comment
Share on other sites

  • 1 month later...

Ok, so I finally gave hope getting my Infini to work correctly as a ZERO consumption unit due to my pre-paid meter tripping.

Due to recommendations by other persons I know I bit the bullet and got myself a Goodwe 5048-ES unit. Everybody that got one has no problems with their pre-paid meters.

To make a long story short, once the Goodwe was installed and running, my pre-paid meter started tripping again :(

After spending many hours with customer support and the manuals, I came to a very small clause in the manual that stats that even when power export is disabled, the unit can still push back up to 100W max.

In the end I had to run about 200W of load before the meter. If the invertor does overshoot a bit, the 200W load should cover that and prevent the pre-paid meter from detecting reverse flow and tripping.

So, for those of you with an Infini can now also start running ZERO consumption as an option.

 

For me running ZERO consumption is the best compromise.

 

Please note that the City Of Cape Town pre-paid meters is programmed to be very sensitive of reverse flow. The bigger the flow, the quicker the meter will trip.

Once detected the meter will disconnect power for 30 seconds. If this happens 5 times within an hour, the meter will disconnect you for 30min.

That is for the Conlog meters. The Landis meters might even go into tamper mode. Then you need a tech to come reset it and you have to pay a R2k fine!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...