Jump to content

Multi II + pylontech high batt alarm with new firmware(474)


Recommended Posts

Multi II 48/5000 + 3 x 3.5kwh Pylontechs on UPS only system

Due to the pylontech sleepmode ESS was activated - that started to throw a Relay error 11 alarm & what is suggested is to 1st start with switch to latest firmware,

It was on 469, upgraded to 474 

Now i'm getting thrown high voltage alarms - i've checked my values & think they are still all the same as previous.

The new alarm

spacer.png

 

This is a 30 day chart where previous there was no peaks in the graph like in the yellow area that i now have had for the last 2 days since doing the FW update.

spacer.png

 

 

Inverter settings are as below

spacer.png

 

spacer.png

 

spacer.png

 

spacer.png

 

spacer.png

 

spacer.png

 

Anybody spot something i'm over looking ?

There was also an ESS assistant update that i did at the same time but those settings also look to be the same as what i previously had without getting this new alarm

 

 

 

 

 

 

 

 

 

 

 

 

Link to post
Share on other sites

What version of Venus are you running? In Veus 2.60, the charge voltage for Pylontech batteries have been increased to 52.4V. Pylontech actually wants us to take it to 52.6V, but that will happen later. In Venus 2.5x, the charge voltage is still 52V. Assuming you have DVCC turned on and all that. The Multi should not be going up that high...

Sometimes the spike in voltage is not the cause of the problem, but the result. If the BMS disconnects because it has a problem with a high cell, that often causes a spike in the measured voltage (because now there is no battery to weigh/dampen it down, just the capacitors on the DC bus).

So my guess is that you have a high cell somewhere, imbalance issue. And you need the BatteryView software to diagnose that, unfortunately.

Link to post
Share on other sites
Posted (edited)

Hi Plonkster,

Venus is on V 2.58, unchanged for for quite some time.

Dvcc yes on 

Its been only since the firmware change + assistant update that i've ever had this error come

2 times its happened has been 0300 + 0500 so i haven't seen if its kicking the batts off yet

Edited by 2una
Link to post
Share on other sites
21 minutes ago, VisN said:

Why do you have your battery capacity at 210 Ah? Should it not be 74 Ah x 3 = 222 Ah?

I doubt that's your problem though.

Just a rough number the installer or myself pulled from somewhere but its been like that since day1.

This is like alarm hopscotch - do something to get rid of 1 alarm & another one comes.......this is now no3 new alarm in attempt to get rid of no2 alarm which is possibly brought on by trying to get rid of no1 alarm........one day we'll get it right hopefully

Link to post
Share on other sites

Hang on... this is a UPS system only? I have a solution for you. In the ESS menu, turn on the option to feed excess DC PV into the grid.

Yes, you don't have actual PV connected, but this causes the Multi to suck high voltages from the battery and send it into the grid.

That's the short version of the answer. The longer version will now follow.

Without the above option, and when not discharging the battery, the Multi will not take energy from the battery. Small bits of energy may however slip into the battery over time, so you end up in a situation where energy goes into the battery but can never come out again. Even 50mA, done enough times, can eventually overvolt a battery.

So why does charge slip into the battery? Becaus e of fluctuations in the AC voltage. The Multi uses PWM control to regulate the charge voltage of the battery, which means there is a control loop that adjusts the duty cycle of that PWM control signal. When the grid voltage rises, the duty cycle has to be reduced, otherwise the battery voltage will rise proportional to the change in the AC voltage. For a few milliseconds, a small amount of current will then flow into the battery, until the PWM ratio is adjusted. As the AC voltage fluctuates, this will slowly add up until the battery overvolts.

By simply turning on the overvoltage feed-in option, as above, the Multi will take that energy and send it back into the grid.

Link to post
Share on other sites

@plonkster, your answer has left me with a couple of questions.

Does this mean that multi doesn't run in parallel with the grid if the option to export excess PV is turned off? (By this I mean it isn't inverting when grid connected, but using a PWM charge method)

If this is the case, then it should be able to drop the current to 0 under all circumstances by stopping the PWM completely. I'm assuming it works the way some other inverters work in this mode by changing the switching mode so it works as a boost converter using the filter inductor as the boost inductor.

If this is not the case (i.e. The inverter does still run in parallel with the grid) then grid voltage fluctuations should pretty much average out to zero, i.e. there will not only be increases in voltage but also dips, which would cause some energy to flow back into the grid briefly.

 

Link to post
Share on other sites
1 minute ago, Stanley said:

@plonkster, your answer has left me with a couple of questions.

I don't have the full details. This is how it was explained to me. The Multi is running parallel with the grid at this point, and you are right that you'd expect it to average out at zero. If the Multi just did nothing (kept the PWM ratio constant and ride it out), then it would average out. But the Multi is trying to hold the voltage at the same place, so little bits slip in, and little bits also slip out (of course), but this is not symmetrical. In practice more slips in than slips out, and this happens because the Multi is actively trying to prevent discharge (because it was told not to discharge).

Of course all of this can be changed, and probably will eventually, but right now the way to avoid it is simply to allow it to feed overvoltage into the grid.

Link to post
Share on other sites
7 minutes ago, Stanley said:

I'm assuming it works the way some other inverters work in this mode by changing the switching mode so it works as a boost converter using the filter inductor as the boost inductor.

I'm not that clued up on the electronic part, so take with a pinch of salt if you will 🙂 The Multi is a low frequency design.  It has a big toroidal transformer with a fixed ratio. Feeding energy into the grid, and taking energy from it, is done by using PWM on the secondary side. You put the voltage in a place where it will cause the current to flow in the direction you want it to go, Johannes explains it here.

Link to post
Share on other sites

Thanks for the input Plonkster - you  think re-enable ESS & add that setting & try huh.

Does this lend any clues? Batt voltage 53V & yet i still see some "charging" going on in that problem area while its throwing out batt high voltage alarms at the same time.

spacer.png
 

The green line is 1st sign of high voltage

The yellow line around the 1st High batt voltage alarm thrown

Link to post
Share on other sites
9 minutes ago, 2una said:

Thanks for the input Plonkster - you  think re-enable ESS & add that setting & try huh.

Yes.

10 minutes ago, 2una said:

still see some "charging" going on

The "battery state" field is derived simply from the battery power. Above 30W... and it is considered "Charging". That's less than 1A. It fits the theory though... that small amounts of charge ends up building up in the battery.

Link to post
Share on other sites
Just now, plonkster said:

Yes.

The "battery state" field is derived simply from the battery power. Above 30W... and it is considered "Charging". That's less than 1A. It fits the theory though... that small amounts of charge ends up building up in the battery.

 

Ok i'll load that ESS back on with that setting & see what happens. 

Thanks !!

Link to post
Share on other sites
1 minute ago, plonkster said:

Yes. In Venus 2.60 it moved to a submenu... and the spelling mistake is fixed (two words in English, solar charger 🙂 ).

I checked for that 2.60 when you mentioned about it - seems its not in the official release yet.(i'm still 2.58 with auto update set to on)

Ok fingers crossed with this attempt, Have load shedding kicked in now & that problem seems to come a few hours after the battery is back charged again so maybe tonight may tell a story

 

Link to post
Share on other sites

Got thru the night with no voltage spike happening with that setting

I notice here on the graph it definitely seems to be a lot busier whilst it would normally be sitting in full charge idle mode - green line is about where the settings was changed which was also right before a 2 hour load shedding. 

 

spacer.png

Plonkster i wonder how difficult it would be to add a Voltage set point to that ESS "feed to grid" setting for them. (LIke here set it at 52.8/53V) OR is that in someway possible to already do?

I'm thinking on one hand we are setting ESS to "keep batteries charged" & on another setting telling it to burn it off (seems to be doing that as soon as it goes above 52.0)  .

If its only trickle amounts i don't really care but on the other hand not too keen if it's something similar to flicking on/off a 100w light bulb all day & night long.

That wiggling i see versus before just seems a little "busy"?  Good with PV but to keep as UPS only? 

Trickle amounts of power going to waste & don't worry or consider reverting back to ignoring the pylontech "sleep" problem & remove ESS you think?

 

Link to post
Share on other sites
34 minutes ago, 2una said:

seems to be doing that as soon as it goes above 52.0)

Correct. The charge voltage is 52V (in 2.60 it will be 52.4V), and when used with MPPTs the MPPTs will be instructed to charge 0.4V higher than this. The Multi feeds in everything above 52V, as you noted.

By enabling it without DC chargers, you're using this same mechanism to deflate it, should it ever go above 52V "by accident".

Also, if you haven't done it, disable SVS (shared voltage sense) in the DVCC menu.

36 minutes ago, 2una said:

wiggling i see versus before just seems a little "busy"?

I agree, which is why I wonder is SVS might be on. Turn it off.

The idea with SVS is that the voltage as reported by the battery is synced to the other devices (Multi, solarcharger), and this will then eliminate calibration differences and voltage drop over the cable. The only trouble is that a highly charged Lithium battery can spike up really quickly, and because the BMS often sends voltage info only once every 2 seconds or so, and that is synced with the other devices only every 3 seconds, it doesn't really work all that well with some batteries. The shared value can be stale by up to 5 seconds be the time things are recalibrated...

The only other thing that will cause some wiggling, is if your AC input limit is set to a lower value. Then the Multi will "assist" when your input current goes above the set limit. For example, I have mine set to 20A, so when we go above 4.5kW draw, the Multi assists from the battery, and recharges afterwards.

Link to post
Share on other sites

Interesting thread.  Axpert inverters are also having similar problems and it was assumed to be because the Axpert is "cheap"/"low quality"/etc.  Seems the Pylontech batteries are super sensitive.

Edited by Gnome
Link to post
Share on other sites
51 minutes ago, Gnome said:

Seems the Pylontech batteries are super sensitive.

They are. Well perhaps not super sensitive, but more sensitive than many others.

They need 3.48V per cell to register a 100% SOC. That's 52.2V. I have it from the horses mouth that you really need 52.6V for this to be reliable. That's 3.5V per cell. Which is not super high, but it's on the wrong end of the elbow point where LFP cells become somewhat spiky. Battery switches off at 54V, or if any one cell goes above 3.6V.

Now keep in mind that calibration differences can easily add 0.5V (that is 1%) into the mix, which mens we have 1.4V margin of which 0.5 has to be kept aside for calibration, which leaves less than 1V room between where the battery registers as full and where it switches off.

Compared to others, this is very tight.

I can say one thing though, and that is that if you have multiple modules in your total battery, it really helps. If there is a high cell in one module, the BMS will disconnect that one module (to prevent overharge), but the other modules in the battery still keep it running. This is something to keep in mind when you design a battery. You're actually better off with two small modules than one large one.

Link to post
Share on other sites

SVS - was already set to off

settings as so - SCS on but looks like overridden to Disabled on the next line below it.

spacer.png

 

AC input setting - I think this is the one you mean here? set to 50A

 

spacer.png

 

 

Link to post
Share on other sites
3 hours ago, Louisvdw said:

Are you talking about cells here or batteries?

Aaaah, the ongoing game of defining your terms.

The way I see it, is the whole thing (all series/parallel strings together) make up one large battery. The battery will consist of one or more modules (in Pylontech land, each 19" rackmount box is a module), and each module will consist of multiple cells.

When you have multiple modules making up your (one) battery, there is generally some way in which the individual BMS components manage the whole. With Pylontech batteries, this allows a module to disconnect from the DC bus, but leave the rest of the battery up and running. If you had one large module, this disconnection event could cause the inverter to turn off. If you had two small ones, the other module remains online. In other words, having more than one module adds some redundancy.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...