Jump to content

Pylontech batteries not draining equally


Recommended Posts

4 hours ago, MartinKoch said:

My second battery has four lights on, 5th flickering, first and last one light on, 2nd flickering, indicating 19% SOC

I cannot speak of Pylontech specifically, but I had this experience with a client of mine who had (newly installed) Coslight batteries. They were imbalanced for the first few weeks. After maybe 3 or 4 weeks of cycling they eventually “found” each other and the lights eventually synchronized. 

There is a video on boobtube showing how it “introduce” new Pylontech  batteries. 

Link to comment
Share on other sites

I have 2 US3000s, one 3 weeks old and the other about 2 months. The newer one doesn't charge to 100% at all, whether it's the master or slave or the only battery on the inverter. It just stops at some point. First day it was 82% then slowly crept up to about 90 at about 1-2% per cycle, then at about 3-4% per cycle to a best of 99%. But now it's gone back down to 90% and is fairly stable.

It's consistently a similar % below the other one. This not only costs me capacity on top but also prevents me cycling the bank as low as I would like. Is this the normal pattern for batteries finding each other, or do I have an issue?

Link to comment
Share on other sites

49 minutes ago, Vassen said:

Have you tried fully charging each battery separately before joining them together and are you wiring them with positive on 1 battery and negative on the other. I have read that newest battery should also be the master. 

How are you charging them? Using CAN or RS485. 
With my US3000, I notice that it gets stuck on 88% soc for some time and then very quickly goes to 100%. 

Tried separately, and as master and slave, new one won't go to 100% irrespective of the rest of the system. Initially the new one was made master but I've tried all permutations to try to fix this. I think it's slave at the moment though. I'll revert.

Cabling is correct. Batteries in parallel, positive to one, negative to the other.

CAN to the Axpert, Console to the Pi for ICC using the official cable. Lights on battery and ICC agree on SOC.

Voltages set at 53.2 but only the old battery gets there. New one stops in the mid 51s

Will take them to full and hold them to see if it goes up. I'm a little under panelled so usually only get full late afternoon for an hour tops before it starts drifting doen again


Link to comment
Share on other sites

20 minutes ago, Hagu13 said:

Voltages set at 53.2 

I would say that this is too high for normal charging of the Pylons. Recommended values here in the forum are 52.5V for Bulk and 51.8V for Float

2 hours ago, Hagu13 said:

It's consistently a similar % below the other one.

A minor difference in SOC is normal in my experience. Here a screenshot of my pack just now. Notice how the voltage is basically the same for all batteries, but the SOC differs. However, they all get to full at one point. When I added my last battery, it would also at the beginning sometimes not get 100%. Usually I would say to give it a few more weeks and it should balance out


36 minutes ago, Hagu13 said:

New one stops in the mid 51s

Is this also the case if you connect it by itself? And does the voltage increase over time or always remains at the same 51.x V?

1 hour ago, Vassen said:

With my US3000, I notice that it gets stuck on 88% soc for some time and then very quickly goes to 100%. 

This apparently is normal behavior for the Pylons. Plonkster wrote a detailed explanation for the why somewhere here in the forum


Link to comment
Share on other sites

I've tried a few voltages from 52.5 to 53.2. I was initially lower but raised it to try to help it fill up. No effect. 

Voltage and amps move around for a few minutes after full but then don't change. Same if it's alone. But I've never parked it full and on charger for more than about an hour so I'll try that.

I find it odd that it improved from 82 to 99% and then went back to 88. Think I'll hold them overnight tonight instead of cycling them and see what happens

Link to comment
Share on other sites

ok so I have some feedback

Yesterday I made the newer battery the master and charged the bank to full. With the old battery at 100% and new battery at 92% the current dropped to zero and there was just the occasional pulse going in. Temperatures went up a little and SOC slowly drifted to 94% on the low one. So similar to before although the 2% drift was new and heartening. Fairly big delta between highest and lowest cells- maybe 0.25v.

Powered the system down and took the old battery away. Let the new one drift down a few % and then charged again. Similarly went to 94% and stopped, but the pulsing every few minutes continued. After a few hours of checking every 15 minutes or so SOC suddenly went to 99% At this point I started watching cell voltages and saw that they were converging slowly. The higher ones were more responsive to upwards spikes but the low ones resting voltage was drifting upwards 

An hour or so later SOC showed 100% but still 0.67AH from maximum, with delta between cells just under 0.2v.

By bedtime I had AH at max and 0.06v between highest and lowest cells.

Left it overnight. By morning the cell deltas are within 0.04v. And temperature has dropped to normal so it doesn't look like it's doing much balancing work. Reconnected the other battery as slave and set it back to solar. It's only going to shallow cycle on the kettle and dishwasher today but I'll pull it down overnight and see if they stay close or diverge.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...